Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
weiteres Problem mit SendObject...
zurück: Unterformulare weiter: Textfeldinhalt eines Formulars in eine Tabelle übernehmen! Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
astrosoft
Im Profil kannst Du frei den Rang ändern


Verfasst am:
25. Feb 2005, 14:10
Rufname:

weiteres Problem mit SendObject... - weiteres Problem mit SendObject...

Nach oben
       

hallo zusammen,

bei mir funktioniert das versenden des Berichtes unter access-2000 wunderbar... aber nur EINMAL!
dabei spreche ich die prozedur nicht aus einer schleife heraus an, sondern über einen button auf dem hauptformular.

beim 2. mal läuft die prozedur ganz normal durch den quellcode, ruft den bericht auf aber irgnoriert quasi (ohne fehler!) den SendObject befehl und schliesst den bericht wie wenn nichts gewesen wäre...
Code:
    DoCmd.SendObject acSendReport, "Performance Review", _
                     "Snapshot Format", an, cc, _
                     "", betreff, mailtext

es sieht aus, als wäre irgend welche variablen oder objekte nicht sauber definiert, aber die variablen an, cc, betreff und mailtext sind ganz normale texte...

hat jemand eine idee... auch zur weiteren fehlersuche?!?

danke schon mal!
astrosoft
Siehe auch weiteres Problem mit SendObject...
lothi
c#, .Net


Verfasst am:
26. Feb 2005, 11:27
Rufname:
Wohnort: Birgisch


AW: weiteres Problem mit SendObject... - AW: weiteres Problem mit SendObject...

Nach oben
       

Hallo

Was meinst beim 2.mal? Der Funktioniert nur einmal dann nie mehr oder
irgenwann funktioniert er wieder.
Wie sieht denn der Rest des Codes aus ich glaub nicht das an diesem Befehl
liegt.
Bist du denn sich das der Code beim 2. mal überhaupt ausgeführt wird.
Setz doch mal einen Haltepunkt in den Code und führe den Code mit F8
schritt für schritt durch dann siehst du wo es hacken könnte.

_________________
Gruss Lothi, der Bastler
Feedback ist die beste Möglichkeit mir zu sagen ob die Antwort geholfen hat!
AC2002, WinXP, Office XP
astrosoft
Im Profil kannst Du frei den Rang ändern


Verfasst am:
02. März 2005, 11:21
Rufname:

workaround... - workaround...

Nach oben
       

hallo,

besten dank für die antwort...
2. mal heisst beim zweiten und allen folgenden versuchen funktioniert es nicht mehr...

ich hab jetzt mal ein detailliertes fehlereingrenzen betrieben...
es liegt daran, dass ich als betreff:
Code:
"DS-Nr: " & Format(DS_Nr,"000000") & ": " & DS_Beschreibung
stehen habe...
wenn ich das format hier rausnehme funktioniert es beliebig oft?!?

muss ich das verstehen???

wenn niemand sonst eine idee für die umgehung des fehlers hat lass ich das eben im unformatierten zustand im betreff...

vielen dank nochmal!
astrosoft
lothi
c#, .Net


Verfasst am:
02. März 2005, 11:41
Rufname:
Wohnort: Birgisch

AW: weiteres Problem mit SendObject... - AW: weiteres Problem mit SendObject...

Nach oben
       

Hallo

Also ich weiss nicht ob die Format funktion Probleme macht.

Du kanns die Zahl eventuell zuerst Formatiert an eine String Variable übergeben und dann in den Betreff einbinden:
Code:
    Dim sFomat As String

    sFormat = Format(DS_Nr, "000000")
    "DS-Nr: " & sFormat & ": " & DS_Beschreibung

_________________
Gruss Lothi, der Bastler
Feedback ist die beste Möglichkeit mir zu sagen ob die Antwort geholfen hat!
AC2002, WinXP, Office XP
Tom2002
Der einzig Wahre Leuchtturm - Pilsum


Verfasst am:
02. März 2005, 12:07
Rufname:
Wohnort: Düsseldorf

AW: weiteres Problem mit SendObject... - AW: weiteres Problem mit SendObject...

Nach oben
       

hi,

das ist ein bug in access 2000.

SP3 löst das Problem.

ciao

tom

_________________
Win7, Win2008 R2, Office 2010 Prof

Wer mit Fortuna Düsseldorf groß geworden ist, der fürchtet sich auch vor Access nicht.
Die Nutzlosigkeit des Daseins anzuerkennen heisst, Fortuna-Fan zu sein.
lothi
c#, .Net


Verfasst am:
02. März 2005, 12:11
Rufname:
Wohnort: Birgisch

AW: weiteres Problem mit SendObject... - AW: weiteres Problem mit SendObject...

Nach oben
       

Hi Tom

Ein Bug in SendObject oder in Format Question

_________________
Gruss Lothi, der Bastler
Feedback ist die beste Möglichkeit mir zu sagen ob die Antwort geholfen hat!
AC2002, WinXP, Office XP
Tom2002
Der einzig Wahre Leuchtturm - Pilsum


Verfasst am:
02. März 2005, 12:21
Rufname:
Wohnort: Düsseldorf


AW: weiteres Problem mit SendObject... - AW: weiteres Problem mit SendObject...

Nach oben
       

hi lothi,

ein Bug in SendObject (SendObject method fails in Access 2000)
Erster Aufruf funzt, der zweite nicht mehr. erst wenn das formular geschlossen wird, wird Sendobject wieder korrekt ausgeführt.

ciao

tom

_________________
Win7, Win2008 R2, Office 2010 Prof

Wer mit Fortuna Düsseldorf groß geworden ist, der fürchtet sich auch vor Access nicht.
Die Nutzlosigkeit des Daseins anzuerkennen heisst, Fortuna-Fan zu sein.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Programmierung / VBA: mit DoCmd.SendObject kein automatischer mailversand.. leider 4 alex120212 127 29. Nov 2013, 13:48
alex120212 mit DoCmd.SendObject kein automatischer mailversand.. leider
Keine neuen Beiträge Access Programmierung / VBA: DoCmd.SendObject mit EditMessage=False funktioniert nicht 1 max_pla3 109 24. Okt 2013, 12:47
me!name DoCmd.SendObject mit EditMessage=False funktioniert nicht
Keine neuen Beiträge Access Programmierung / VBA: SendObject in AccessRuntime 2007 0 MartinESG 81 18. Apr 2013, 17:45
MartinESG SendObject in AccessRuntime 2007
Keine neuen Beiträge Access Programmierung / VBA: SendObject => Nachrichtentext aus Kombifeld mit Variablen 10 Robeat 410 25. März 2012, 21:01
MissPh! SendObject => Nachrichtentext aus Kombifeld mit Variablen
Keine neuen Beiträge Access Programmierung / VBA: Syntaxfrage DoCmd.SendObject 2 Nikolai 201 29. Feb 2012, 11:26
Nikolai Syntaxfrage DoCmd.SendObject
Keine neuen Beiträge Access Programmierung / VBA: DoCmd.SendObject mit 2 Formaten? 1 Gast 711 13. Mai 2011, 13:06
Gast DoCmd.SendObject mit 2 Formaten?
Keine neuen Beiträge Access Programmierung / VBA: SendObject Lotus Notes 0 LeiniMD 729 09. Mai 2011, 12:04
LeiniMD SendObject Lotus Notes
Keine neuen Beiträge Access Formulare: mehrere Anhänge mit DoCmd.SendObject 1 Smmmile 1349 04. März 2011, 17:08
Gast mehrere Anhänge mit DoCmd.SendObject
Keine neuen Beiträge Access Programmierung / VBA: SendObject, kursiv? 1 boundin 519 21. Jan 2011, 17:58
lleopard SendObject, kursiv?
Keine neuen Beiträge Access Programmierung / VBA: *.doc Dateien mit sendobject anhängen? 4 Engelking 792 11. Aug 2010, 15:00
Engelking *.doc Dateien mit sendobject anhängen?
Keine neuen Beiträge Access Programmierung / VBA: DoCmd.SendObject acSendReport kein Error als Rückgabe 2 STAINLESS-44 1430 05. Jul 2010, 19:43
Gast DoCmd.SendObject acSendReport kein Error als Rückgabe
Keine neuen Beiträge Access Berichte: WhereCondition in Sendobject für Bericht 13 Blek 819 29. Jan 2010, 10:28
Blek WhereCondition in Sendobject für Bericht
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum