Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Summenprodukt und Mittelwert
zurück: Makro-Diagrammerstellung mit variierenden Datenberreich??? weiter: Denkblockade oder doch unlösbares Problem? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Jessi75
Gast


Verfasst am:
19. Jan 2009, 11:16
Rufname:

Summenprodukt und Mittelwert - Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hallo

ich komme mit meiner Formel nicht klar. Wahrscheinlich ist es wieder was ganz Logisches aber ich komme nicht drauf.

Ich habe eine Datei wo Verkaufsergebnisse eingegeben werden. Dann gibt es eine zweite Datei, wo die erste ausgewertet wird. Auf die zweite haben auch mehrere Personen Zugriff. Die Datei ist so aufgebaut, dass ich in Spalte A die Verkäufernummer habe und daneben für jeden Monat die Stückzahlen stehen. Meine Formel sieht so aus:

Code:
=SUMMENPRODUKT((MONAT('[Verkauf 2009.xls]1'!$C$2:$C$2501)=1)*(JAHR('[Verkauf 2009.xls]1'!$C$2:$C$2501)=2009)*('[Verkauf 2009.xls]1'!$E$2:$E$2501=$A45))


Diese Formel funktionert auch.

Nun habe ich in Spalte O den Nachlass. Ich möchte nun eine separate Auswertung woraus der durchschnittliche Nachlass des einzelnen Verkäufers hervorgeht. Das Format der Spalte ist Prozent.

Ich hab das mal mit Mittelwert versucht aber das Ergebnis stimmt nicht.

Hoffe, ihr könnt mir helfen.

Danke
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
19. Jan 2009, 19:01
Rufname:
Wohnort: Oldenburg i.O.


Re: Summenprodukt und Mittelwert - Re: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hi,

wenn ich das richtig sehe, zählt Deine Formel die ANZAHL der Aktivitäten eines Verkäufers (A45) in dem jeweiligen Zeitraum.

Für die Ermittlung der Summe Rabatte fehlt wohl noch der Umsatz und der damit multiplizierte Rabattsatz:
Zitat:
=SUMMENPRODUKT((MONAT('[Verkauf 2009.xls]1'!$C$2:$C$2501)=1)*(JAHR('[Verkauf 2009.xls]1'!$C$2:$C$2501)=2009)*('[Verkauf 2009.xls]1'!$E$2:$E$2501=$A45)*SpaltenUmsatz*SpaltenRabatte)


Allgemeines zu SUMMENPRODUKT (beachte ggf. Hinweise zu "Semikolon") Thema: Summenprodukt
Evtl. eine Alternative zu Summenprodukt: Thema: Datenbank-Funktionen - dort gibts DBSUMME, DBMITTELWERT...

_________________
urs grüßt
Jessi75
Gast


Verfasst am:
20. Jan 2009, 16:17
Rufname:

AW: Summenprodukt und Mittelwert - AW: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hallo

ja, das ist die ursprüngliche Formel womit ich die Stückzahlen wiedergebe. In Spalte O steht der Nachlass in %. Ich möchte den durchschnittlichen Nachlass in % je Verkäufer ermitteln. Muss ja nicht mit summenprodukt sein. Kann ich mit der DB Formel auch die Verkäufer einschränken oder wird mir dann der Mittelwert aller Verkäufe ausgegeben?
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
20. Jan 2009, 19:06
Rufname:
Wohnort: Oldenburg i.O.

AW: Summenprodukt und Mittelwert - AW: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hi,

dann Du brauchst für die Berechnung ja noch den Verkäufer und den Umsatz (Formel bezügl. Bereiche vereinfacht; Annahmen für Spalten; "aa" steht für einen selektierten Verkäufer):
Zitat:
=SUMMENPRODUKT((MONAT(C2:C10)=1)*(JAHR(C2:C10)=2009)*(A2:A10="aa")*F2:F10)

und in einer zweiten Formel den Rabatt
Zitat:
=SUMMENPRODUKT((MONAT(C2:C10)=1)*(JAHR(C2:C10)=2009)*(A2:A10="aa")*F2:F10*G2:G10)

_________________
urs grüßt
Jessi75
Gast


Verfasst am:
21. Jan 2009, 10:41
Rufname:

AW: Summenprodukt und Mittelwert - AW: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hallo

der fette Teil sucht den Verkäufer. Ich habe mal in Spalte L den Umsatz und AF den Rabatt in % mit eingebaut. Ergebnis ist immer #Wert. Ich habe ja schon den Rabatt als % Zahl bei jedem einzelnen Verkauf. Wenn jetzt verkäufer A 2 Einheiten verkauft hat, einmal mit 10% und einmal mit 5% soll in der Auswertung ein durchschn. Nachlass von 7,5% stehen.

Code:
=SUMMENPRODUKT((MONAT('[Verkauf NW 2009.xls]NW'!$C$2:$C$2501)=1)*(JAHR('[Verkauf NW 2009.xls]NW'!$C$2:$C$2501)=2009)*([b]'[Verkauf NW 2009.xls]NW'!$E$2:$E$2501=$A42[/b])*('[Verkauf NW 2009.xls]NW'!$L$2:$L$2500)*'[Verkauf NW 2009.xls]NW'!$AF$2:$AF$2500)
Jessi75
Gast


Verfasst am:
21. Jan 2009, 11:52
Rufname:

AW: Summenprodukt und Mittelwert - AW: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Ich hab jetzt diese Formel probiert und es scheitert am Monat. Sobald ich den "Monat-Teil" weg nehme, funktioniert die Formel. Was läuft mit den Monaten schief?

Code:
{=MITTELWERT(WENN(('[Verkauf NW 2009.xls]NW'!$E$2:$E$2501=$A42)[color=blue]*(MONAT('[Verkauf NW 2009.xls]NW'!$C$2:$C$2503)=1)[/color];'[Verkauf NW 2009.xls]NW'!$AF$2:$AF$2501))}
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
21. Jan 2009, 16:14
Rufname:
Wohnort: Oldenburg i.O.


AW: Summenprodukt und Mittelwert - AW: Summenprodukt und Mittelwert

Nach oben
       Version: Office 2003

Hi,

die Bezüge in Deiner Formel sind nicht gleich groß.

Den Mittelwert über alle gültigen Zellen würde ich auch mit einer Matrixformel (oder DBMITTELWERT) berechnen.

Es ist noch abhängig davon, wie der Mittelwert gebildet werden soll:
Code:
{=MITTELWERT(WENN((C2:C10>=DATWERT("1.1.2009"))*(C2:C10<DATWERT("1.2.2009"))*(E2:E10=A42);AF2:AF10))}
... für alle Zellen des Verkäufers
Code:
{=MITTELWERT(WENN((C2:C10>=DATWERT("1.1.2009"))*(C2:C10<DATWERT("1.2.2009"))*(E2:E10=A42)*(AF2:AF10<>0);AF2:AF10))}
... für alle Zellen des Verkäufers mit Eintrag im Rabattfeld = mittlerer Rabatt über jene, für die überhaupt Rabatte gewährt wurden.

Und, wie oben schon erwähnt, kann es sinnvoll sein, die Summe des Rabatts dem Gesamt-Umsatz gegenüberzustellen. Das hätte wohl etwas mehr "Aussagekraft"...

_________________
urs grüßt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Mittelwert und Autofilter? 3 stommy7 904 26. Jul 2006, 11:43
stommy7 Mittelwert und Autofilter?
Keine neuen Beiträge Excel Formeln: Mittelwert aller positiven Zahlen ?? 4 jungUNDdumm 1712 19. Jul 2006, 13:10
jungUNDdumm Mittelwert aller positiven Zahlen ??
Keine neuen Beiträge Excel Formeln: SUMMENPRODUKT Ausgabe mit Texten 5 Gast123456 1724 06. Jul 2006, 14:57
Alto SUMMENPRODUKT Ausgabe mit Texten
Keine neuen Beiträge Excel Formeln: MIttelwert mit Nullwerten 5 Gast 783 04. Jul 2006, 10:41
c0bRa MIttelwert mit Nullwerten
Keine neuen Beiträge Excel Formeln: mittelwert ohne bestimmte zahlen 6 Sändu 1085 21. Jun 2006, 15:29
Sändu mittelwert ohne bestimmte zahlen
Keine neuen Beiträge Excel Formeln: Produktvarianten in SUMMENPRODUKT Formel knapp zusammenfasse 4 SteffenS 1006 09. Jun 2006, 07:32
SteffenS Produktvarianten in SUMMENPRODUKT Formel knapp zusammenfasse
Keine neuen Beiträge Excel Formeln: Mittelwert pro Monat berechnen 8 Kaska 1597 31. Mai 2006, 19:34
fridgenep Mittelwert pro Monat berechnen
Keine neuen Beiträge Excel Formeln: Summenprodukt #nv unterdrücken 3 etron795 4133 17. März 2006, 22:47
etron795 Summenprodukt #nv unterdrücken
Keine neuen Beiträge Excel Formeln: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet) 12 MET 13949 21. Feb 2006, 20:35
rainberg Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)
Keine neuen Beiträge Excel Formeln: Mittelwert von absoluten Zahlen (Betrag) ?!? 8 derschroe 5648 12. Okt 2005, 15:14
derschroe Mittelwert von absoluten Zahlen (Betrag) ?!?
Keine neuen Beiträge Excel Formeln: Mittelwert 1 dennism 613 27. Sep 2005, 13:27
fridgenep Mittelwert
Keine neuen Beiträge Excel Formeln: summenprodukt - mit oder kriterium 3 chrispx 8071 23. Aug 2005, 11:44
chrispx summenprodukt - mit oder kriterium
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen