Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
unterscheidung zwischen text und zahlen in einer Zelle
zurück: Zellenmarkierung weiter: NBVAL findet mehr Namen als es gibt. Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
hmmmmm???
Gast


Verfasst am:
01. Feb 2005, 16:17
Rufname:

unterscheidung zwischen text und zahlen in einer Zelle - unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Hallo,
ich habe folgendes problem:
in der Zelle B2 habe ich eine formel z.B: =wenn(a1="n.n";"n.n <"& 2*10;2*10)
er gibt dann in B2 folgendes aus, wenn in A1 n.n steht: n.n< 20

für eine nächste berechnung in zelle B3 benötige ich jetzt die 20 als Zahl.
wenn ich aber nun die Formel: =B2*100 eingebe, rechnet er nicht weil er die n.n< als Zahl erkennt und somit nicht rechnen kann!

Hoffe nun das mir einer sagen kann wie ich es fertig bringe das er aus Zelle B2 nur die 20 als Zahl erkennt und das was ich in der formel in " geschrieben habe nicht.

Dank schonmal im vorraus!!! Razz
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Feb 2005, 17:10
Rufname:


AW: unterscheidung zwischen text und zahlen in einer Zelle - AW: unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Hallo,
ob die Art Deiner Berchnungen sehr günstig ist, kann ich nicht beurteilen.
In diesem Falle schreibe ib B3:
=RECHTS(B2;2)*100

Gruß Arnim
hmmmmm???
Gast


Verfasst am:
02. Feb 2005, 10:34
Rufname:

AW: unterscheidung zwischen text und zahlen in einer Zelle - AW: unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Danke erstmal!

aber mit dem Befehl geht des leider net, da die Zahl nie die selbe größe hat.
Also ich führe ne berechnung durch im bereich von 0,00 bis 100,00. und bei =rechts. muss ich ja angeben wieviel zeichen er kopieren soll!

ist es nicht irgendwie möglich das Excel erkennt das die in " geschriebenen zeichen Text sind?, weil ich habe ja =wenn(a1="n.n" usw)?

Ich könnt das problem natürlich über umwege umgehen, nur währe für mich bei dem excel-sheet, n ziemlicher Aufwand und macht das ganze net übersichtlicher!!! Wink
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
02. Feb 2005, 10:48
Rufname:

AW: unterscheidung zwischen text und zahlen in einer Zelle - AW: unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Hallo,
vielleicht geht es so:
=RECHTS(B2;LÄNGE(B2)-FINDEN("<";B2;1))*1

Gruß Arnim
Arnim
Im Profil kannst Du frei den Rang ändern


Verfasst am:
02. Feb 2005, 10:58
Rufname:

AW: unterscheidung zwischen text und zahlen in einer Zelle - AW: unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Hallo,
da ich nicht weiß, ob Deine erste Formel in B2 immer ein "<"-Zeichen hat, dann solltest Du evtl. ein Leerzeichen einfügen, etwa so:
=WENN(A1="n.n";"n.n<"&" "& 2*100;2*100)
Dann wäre die Formel in B3 so:
=RECHTS(B2;LÄNGE(B2)-FINDEN(" ";B2;1))*1*100
oder auch so:
=WENN(ISTTEXT(A1);RECHTS(B2;LÄNGE(B2)-FINDEN(" ";B2;1))*1*100;A1*100)

Gruß Arnim
hmmmmm???
Gast


Verfasst am:
02. Feb 2005, 12:13
Rufname:


AW: unterscheidung zwischen text und zahlen in einer Zelle - AW: unterscheidung zwischen text und zahlen in einer Zelle

Nach oben
       

Danke für die schnelle antwort!

Is echt ne gute idee, so wie du das vorschlägst. Würde theoretisch auch funktionieren, ist bloß bei meinem projekt praktisch etwas ungeschickt einzubauen!!! (zumindest für mich Wink ) Sad

Werd dann halt doch den Umweg über n paar zusätzliche wenn-Verschachtelungen nehmen!!!

Aufjedenfall mal merci, für die tipps!!!! Razz
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Text & Datum Frage 2 AkDS_Kingpin 2798 19. Sep 2004, 14:11
fl618 Text & Datum Frage
Keine neuen Beiträge Excel Formeln: kursive Zahlen mit Makro berechnen? 2 abidmon 827 10. Sep 2004, 15:52
abidmon kursive Zahlen mit Makro berechnen?
Keine neuen Beiträge Excel Formeln: auch negative Zahlen links zählen 17 Red Hair 1629 04. Sep 2004, 14:32
ae auch negative Zahlen links zählen
Keine neuen Beiträge Excel Formeln: übernehmen von werten in eine andere zelle 6 Gast 3717 21. Aug 2004, 18:38
alex81 übernehmen von werten in eine andere zelle
Keine neuen Beiträge Excel Formeln: Addieren von negativen Zahlen 1 cnettekoven 612 12. Aug 2004, 11:04
lala Addieren von negativen Zahlen
Keine neuen Beiträge Excel Formeln: Eigabe nur in einer Zelle zulassen 1 pkegelking 1645 11. Aug 2004, 10:42
icke Eigabe nur in einer Zelle zulassen
Keine neuen Beiträge Excel Formeln: Löschen des Zellinhaltes/von anderer Zelle 2 Gast 1962 07. Aug 2004, 23:32
Gast Löschen des Zellinhaltes/von anderer Zelle
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Negative Zahlen 1 mika2002 604 06. Aug 2004, 08:15
steve1da Negative Zahlen
Keine neuen Beiträge Excel Formeln: Text in verschiedene Zellen aufteilen 5 Thompsen 2069 30. Jul 2004, 13:12
Gast Text in verschiedene Zellen aufteilen
Keine neuen Beiträge Excel Formeln: Formel in der eine gefärbte Zelle eine Bedingung ist...? 10 IMDuggy 2975 14. Jul 2004, 11:17
xpecidy Formel in der eine gefärbte Zelle eine Bedingung ist...?
Keine neuen Beiträge Excel Formeln: zahlen in formel umwandeln 9 eraser 1131 09. Jul 2004, 12:26
ae zahlen in formel umwandeln
Keine neuen Beiträge Excel Formeln: EXCEL97: Zahl anhand von Text suchen? 1 Gast 821 04. Jun 2004, 20:02
Arnim EXCEL97: Zahl anhand von Text suchen?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web Forum