Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Filter funktioniert nicht
zurück: Unterformular: Leere Spalten entfernen & Größe anpassen weiter: Bedingte Formatierung Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
eiskalterengel
Macher


Verfasst am:
13. Nov 2008, 13:50
Rufname:
Wohnort: Hildesheim

Filter funktioniert nicht - Filter funktioniert nicht

Nach oben
       Version: Office 2003

Code:
    Me.Filter = "6069pa_vo_nr = [Forms]![frmPA-DB]![frmPA-DB]![pa_vo_nr]"
    Me.FilterOn = True
funktioniert nicht.
Zitat:
Sie können diesem Objekt keinen Wert zuweisen
Ich brauche aber die Herleitung vom HFO.
_________________
Exzellenz ist eine Frage des Umfeldes.
lleopard
IT Datenbankentwickler


Verfasst am:
13. Nov 2008, 14:00
Rufname: leo


AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

moin,

könnte es daran liegen:
Code:
    Me.Filter = " "6069pa_vo_nr = [Forms]![frmPA-DB]![frmPA-DB]![pa_vo_nr]"
das er nämlich [Forms]!... nicht auflösen kann?

Was is wenn du vorher den Filter auflöst? Also
Code:
    Dim FilterVariable As String
   
    FilterVariable = "6069pa_vo_nr = " & Forms![frmPA-DB]![frmPA-DB]!pa_vo_nr
' und dann sagst:
    Me.Filter = FilterVariable
Könnte schon eher klappen, oder?

Andere Frage: Warum stelle ich in einem Formular einen Filter ein, wenn ich das auch gleich im RecordSource machen kann?
Code:
    Me.RecordSource = "SELECT * FROM Quelle " & _
                       "WHERE 6069pa_vo_nr ="  '...
Dann habe ich genau dasselbe Ergebnis, nur besser.

Was ist zB wenn das Ergebnis Null ist? Prüfe ich das nicht vorher besser?
Code:
    Dim cc As Long
   
    cc = DCount("*", "Quelle", "6069pa_vo_nr = " & "...")
    If cc = 0 Then
    ' ...
Naja, da hat jeder scheinbar seine Vorlieben! Wink

Gruß leo

_________________
Gruß Leo

Honnit soit qui mal y pense!
eiskalterengel
Macher


Verfasst am:
13. Nov 2008, 14:06
Rufname:
Wohnort: Hildesheim

AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

Obiges Beispiel funktioniert nicht. Gleicher Fehler.

Kein RS, weil 1. ich eben auch leere Felder benötige, falls noch nicht vorhanden.

2.
Code:
"SELECT * FROM Quelle WHERE 6069pa_vo_nr =" ....
nicht klappen kann, weil eben die Tabelle "Quelle" die Werte ERST über die ID vom HFO als Standardwert speichert.

Wie bloss anstellen? :-/

_________________
Exzellenz ist eine Frage des Umfeldes.
lleopard
IT Datenbankentwickler


Verfasst am:
13. Nov 2008, 14:59
Rufname: leo

AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

hier war ein Fehler drin, ein " zuviel...
Code:
    FilterVariable = "6069pa_vo_nr = " & Forms![frmPA-DB]![frmPA-DB]!pa_vo_nr
ist natürlich richtig!
_________________
Gruß Leo

Honnit soit qui mal y pense!
eiskalterengel
Macher


Verfasst am:
13. Nov 2008, 15:05
Rufname:
Wohnort: Hildesheim


AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

Ja, hatte ich gesehen - funktioniert dennoch nicht.
_________________
Exzellenz ist eine Frage des Umfeldes.
Willi Wipp
Moderator


Verfasst am:
13. Nov 2008, 17:11
Rufname:
Wohnort: Raum Wiesbaden

Re: Filter funktioniert nicht - Re: Filter funktioniert nicht

Nach oben
       Version: Office 2003

Hi eiskalterengel,

wie kann man denn einen Objektnamen mit einer Zahl beginnen lassen Wink
Code:
    Me.Filter = "[6069pa_vo_nr] = [Forms]![frmPA-DB]![frmPA-DB]![pa_vo_nr]"
Wenn man den Formular-Steuerelement-Bezug aus dem String heraus nimmt, ist der Felddatentyp zu beachten!
_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
eiskalterengel
Macher


Verfasst am:
14. Nov 2008, 09:21
Rufname:
Wohnort: Hildesheim

AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

Hallo Willi,

was so viel heisst wie...? Datentyp für die Nr ist Long.

Wie krieg ich mein Problem gelöst? Smile

_________________
Exzellenz ist eine Frage des Umfeldes.
Willi Wipp
Moderator


Verfasst am:
14. Nov 2008, 11:29
Rufname:
Wohnort: Raum Wiesbaden

Re: Filter funktioniert nicht (II) - Re: Filter funktioniert nicht (II)

Nach oben
       Version: Office 2003

Hi eiskalterengel,

was funktioniert denn an meinem Ansatz nicht?
Ist sicher gestellt das pa_vo_nr einen Wert besitzt oder kann es auch einen Null-Wert haben (nicht 0; sondern nicht belegt)

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
eiskalterengel
Macher


Verfasst am:
14. Nov 2008, 11:32
Rufname:
Wohnort: Hildesheim


AW: Filter funktioniert nicht - AW: Filter funktioniert nicht

Nach oben
       Version: Office 2003

Hallo Willi,

ich hatte ein Zeichen vergessen. Es funktioniert prima.

Ich danke dir und ein schönes Wochenende Smile

_________________
Exzellenz ist eine Frage des Umfeldes.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage funktioniert nicht...hilfe!!!!! 2 bennie103 603 22. März 2007, 21:14
Gast Abfrage funktioniert nicht...hilfe!!!!!
Keine neuen Beiträge Access Tabellen & Abfragen: SQL In mit mehreren Werten funktioniert nicht 5 lullus 702 30. Jan 2007, 20:53
jens05 SQL In mit mehreren Werten funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Kriterium funktioniert nicht!!! 5 christoph.1982 680 25. Jan 2007, 22:18
Nouba Kriterium funktioniert nicht!!!
Keine neuen Beiträge Access Tabellen & Abfragen: Beziehung mit verknüpfter Tabelle funktioniert nicht 4 Thom@s 680 09. Dez 2006, 16:15
Thom@s Beziehung mit verknüpfter Tabelle funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Aktualisierungsabfrage funktioniert nicht. 1 Lady_S 622 18. Sep 2006, 19:10
rita2008 Aktualisierungsabfrage funktioniert nicht.
Keine neuen Beiträge Access Tabellen & Abfragen: Summe funktioniert nicht 15 NotoriousOTW 1380 13. Sep 2006, 00:16
Willi Wipp Summe funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Filter für Anzeigeformular 2 chris1337 687 10. Mai 2006, 08:27
chris1337 Filter für Anzeigeformular
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage mit variablem Filter A2K 5 Gast 983 18. Apr 2006, 11:52
Gast Abfrage mit variablem Filter A2K
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage Kriterium funktioniert nicht... 3 mirco 776 21. März 2006, 15:46
lothi Abfrage Kriterium funktioniert nicht...
Keine neuen Beiträge Access Tabellen & Abfragen: Count() Funktion in Abfrage funktioniert nicht 1 Nike 889 31. Jan 2006, 19:44
jens05 Count() Funktion in Abfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Stichwort Filter Abfrage 3 AIGE 5749 30. Jan 2006, 19:14
accessmichel Stichwort Filter Abfrage
Keine neuen Beiträge Access Tabellen & Abfragen: Mehrere Abfragen als filter für Tabelle in Formular ausgeben 0 artecnet 1012 27. Jan 2006, 10:27
artecnet Mehrere Abfragen als filter für Tabelle in Formular ausgeben
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel-Formeln