Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Mehrere Wörter in einem Text suchen. Wenn eines vorhanden ..
Gehe zu Seite 1, 2  Weiter
zurück: Exeltabelle weiter: Buchstaben selektieren Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
svenk
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2008, 17:44
Rufname:

Mehrere Wörter in einem Text suchen. Wenn eines vorhanden .. - Mehrere Wörter in einem Text suchen. Wenn eines vorhanden ..

Nach oben
       Version: Office 2k (2000)

Hallo,

ich möchte in einer Zelle ein 'X' setzen, wenn ein oder mehrere Wörter aus einer Liste von Wörtern in einer anderen Zelle vorhanden sind. Natürlich wäre es mir ganz lieb wenn ich die Wörter in einem extra Tabellenblatt pflegen könnte und somit nicht immer die Formel anpassen muss.

Bsp.:

gesuchte Wörter: Text, Auto, Blume

Text aus der zu durchsuchenden Zelle: "Das ist ein Text mit vielen Wörtern."

Ergebnis: X -> da das Wort 'Text' in der Zelle vorkommt.

Groß und Kleinschreibung soll nicht beachtet werden.

Habe es wie folgt versucht:
Code:

=WENN(ODER(FINDEN("Text";D5));"X";)


Das klappt auch ganz gut wenn ich nur ein ODER Argument habe. Bei mehreren klappt das aber nicht mehr bzw. nur wenn er alle findet. Sollte doch aber mit oder anders sein, oder?

Code:

=WENN(ODER(FINDEN("Text";D5);FINDEN("Auto";D5));"X";)


Danke euch schon einmal für eure Antworten.

Viele Grüße,

Sven
Janni 07
Gast


Verfasst am:
24. Sep 2008, 18:09
Rufname:


AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

'N Abend,

passt es so?

Tschüss Janni

Tabelle2

 ABCD
1SuchWörter  Beispiele
2Text xDas ist ein Text mit vielen Wörtern.
3Blume  Das ist ein Satz mit vielen Wörtern.
4Auto xDas ist eine Blume mit vielen Blättern.
5   Das ist ein Baum mit vielen Blättern.
6  xDas ist ein Auto mit vier Rädern.
7   Das ist ein Laster mit vier Rädern.

Formeln der Tabelle
ZelleFormel
C2=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D2)));"x";"")
C3=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D3)));"x";"")
C4=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D4)));"x";"")
C5=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D5)));"x";"")
C6=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D6)));"x";"")
C7=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D7)));"x";"")


Excel Jeanie Html
svenk
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2008, 19:52
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2003

Danke für deine Hilfe. Es funktioniert schon mal für einzelne Zeilen.

In Office 2003 (habe auf Arbeit Office 2000, gibt es da unterschiede) passt aber der Bezug zu den Texten nicht mehr, wenn ich die Formel in die anderen Felder der Spalte kopiere, da er einen Zeilenbezug einbaut der sich auf die aktuelle Zeile bezieht. Kann ich den auch absolut angeben?

Bespiel jetzt:

Code:

=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(Texte!ZS:Z(1)S;ZS(1))));"x";"")


Paßt super, wenn ich die erste Zeile prüfe. In Zeile zwei und höher passt das natürlich nicht mehr, da meine Vergleichstexte ja in Zeile 1 und 2 bleiben.
Janni 07
Gast


Verfasst am:
24. Sep 2008, 20:11
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

'N Abend,

die Dollarzeichen in der Formel hast du gesehen? Dadurch wird der Bezug beim runterkopieren fixiert.
=WENN(SUMMENPRODUKT(1*ISTZAHL(SUCHEN(A$2:A$4;D2)));"x";"")

Tschüss Janni
svenk
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2008, 20:16
Rufname:


AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Gibt es da unterschiede in neueren Officeversionen mit dem absoluten Zellbezug?
(office 2003)
Gast



Verfasst am:
24. Sep 2008, 20:22
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Nein!
svenk
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Sep 2008, 20:46
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Vielen Dank.
Edward01
Gast


Verfasst am:
12. Jan 2010, 13:34
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2003

Hey Janni 07,

aufbauend auf diesem Thread folgende Frage:

Ich möchte anstelle des "x" den Suchbegriff ausgeben lassen.

Hab mich schon durch mehrere Foren gegooglet und nix gefunden. Weißt Du Rat?

Schon im Voraus 1001 Dank.

Gruß, Edward01
Janni 07
Gast


Verfasst am:
12. Jan 2010, 17:40
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Tag,

hier ist eine Lösung.

Tschüss Janni

 ABCD
1Suchwörter  Beispiele
2Text TextDas ist ein Text mit vielen Wörtern.
3Blume #NVDas ist ein Satz mit vielen Wörtern.
4Auto BlumeDas ist eine Blume mit vielen Blättern.
5  #NVDas ist ein Baum mit vielen Blättern.
6  AutoDas ist ein Auto mit vier Rädern.
7  #NVDas ist ein Laster mit vier Rädern.

ZelleFormel
C2=VERWEIS(2;1/FINDEN(A$2:A$4;D2);A$2:A$4)
C3=VERWEIS(2;1/FINDEN(A$2:A$4;D3);A$2:A$4)
C4=VERWEIS(2;1/FINDEN(A$2:A$4;D4);A$2:A$4)
C5=VERWEIS(2;1/FINDEN(A$2:A$4;D5);A$2:A$4)
C6=VERWEIS(2;1/FINDEN(A$2:A$4;D6);A$2:A$4)
C7=VERWEIS(2;1/FINDEN(A$2:A$4;D7);A$2:A$4)
edward01
Im Profil kannst Du frei den Rang ändern


Verfasst am:
12. Jan 2010, 18:00
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Hey Janni,

top, top, top! Vielen Dank.

Der Fall ist damit geschlossen, für mich.

Gruß, Edward.
findinggood
Gast


Verfasst am:
04. Apr 2012, 15:09
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Juhuuuu, vielen lieben Dank! Nach stundenlanger Suche bin ich endlich auf dieses Forum hier gestoßen und jetzt hab ichs auch. Super! Smile
findinggood
Gast


Verfasst am:
04. Apr 2012, 15:10
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Juhuuuu, vielen lieben Dank! Nach stundenlanger Suche bin ich endlich auf dieses Forum hier gestoßen und jetzt hab ichs auch. Super! Smile
blueeye70
Im Profil kannst Du frei den Rang ändern


Verfasst am:
09. Jul 2012, 15:33
Rufname:
Wohnort: Olten

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Hallo Leute

Ich habe ein ähnliches Problem, kriege es aber trotzdem nicht hin.

Ich habe eine Liste mit unterschiedlichen Werten, z.B.:

1571.21.3.070
1571.21.3.090
1571.21.4.070
1571.21.6.060
1571.25
1571.25.125

Ich möchte nun per formel nach den Werten (.21 / .25 und weitere) suchen und falls diese da sind, diese auch in einer anderen spalte in der gleichen Zeile reinschreiben - also in dem Fall 21 oder 25.
Das klappt so weit schon mal ganz gut. Nun suche ich aber auch Werte wie .07
In der dritten Zeile vom Beispiel gibt er mir dann 07 zurück anstelle von 21.

Kann mir da jemand helfen?
Ich kriegs einfach nicht hin.
ruettimann
Gast


Verfasst am:
21. Aug 2012, 16:40
Rufname:

AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2010

Yes, das ist genau das, wonach ich gesucht habe. Vielen Dank den Spezialisten!!
(juppi, nun kann ich weitermachen mit der Arbeit..)
michael-scully
Im Profil kannst Du frei den Rang ändern


Verfasst am:
18. Jan 2013, 11:47
Rufname:


AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande - AW: Mehrere Wörter in einem Text suchen. Wenn eines vorhande

Nach oben
       Version: Office 2k (2000)

Hallo, kann mir jemand erklären was das "2;1" zu beginn der Formel "=VERWEIS(2;1/SUCHEN(....etc." bedeutet, verstehe die Logik nicht ganz.

Wie muss die Formel aufgebaut sein, wenn z.B mehrere Wörter gefunden / gesucht werden sollen, also man z.B Baum und Auto in der Ergebniszelle ausgeben will, sofern diese in der Suchzelle enthalten sind.

Vielen Dank schon mal
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Den zum Maximalwert zugehörigen Text anzeigen? 6 Florian 1523 01. Jul 2005, 11:50
Florian Den zum Maximalwert zugehörigen Text anzeigen?
Keine neuen Beiträge Excel Formeln: SUMME wenn in der Spalte Text und Zahl steht ??? 8 Inge 1750 30. Mai 2005, 11:40
Inge SUMME wenn in der Spalte Text und Zahl steht ???
Keine neuen Beiträge Excel Formeln: Funktion "SUCHEN" 2 Claudia36 1461 19. Mai 2005, 17:18
Claudia36 Funktion "SUCHEN"
Keine neuen Beiträge Excel Formeln: in Formel automat. Text einbauen - geht das überhaupt ?!? 4 peter.pen 941 20. Apr 2005, 23:56
Hübi in Formel automat. Text einbauen - geht das überhaupt ?!?
Keine neuen Beiträge Excel Formeln: text zählen 4 roli 1885 28. Jan 2005, 12:34
Kuwe text zählen
Keine neuen Beiträge Excel Formeln: Nach Zeichenketten in Feldern suchen 9 Jan-Jakob Meyer 858 04. Jan 2005, 15:11
Jan-Jakob Meyer Nach Zeichenketten in Feldern suchen
Keine neuen Beiträge Excel Formeln: Suchen nach bestimmten Formatierungen 1 *** Lydia *** 517 20. Dez 2004, 11:21
ae Suchen nach bestimmten Formatierungen
Keine neuen Beiträge Excel Formeln: 2 Daten miteinander vergleichen, wenn gleich dann Text 1 BennyII 4347 11. Dez 2004, 12:00
ae 2 Daten miteinander vergleichen, wenn gleich dann Text
Keine neuen Beiträge Excel Formeln: Problem mit Suchen/Ersetzen 1 Benni 730 24. Nov 2004, 23:04
Reinhard Problem mit Suchen/Ersetzen
Keine neuen Beiträge Excel Formeln: Text einer Zelle aufteilen 2 Gast Chris 2786 28. Okt 2004, 12:32
Gast Chris Text einer Zelle aufteilen
Keine neuen Beiträge Excel Formeln: Text & Datum Frage 2 AkDS_Kingpin 2798 19. Sep 2004, 14:11
fl618 Text & Datum Frage
Keine neuen Beiträge Excel Formeln: Wert in einem Bereich suchen. 5 khummel 16979 16. Sep 2004, 19:54
khummel Wert in einem Bereich suchen.
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP Forum