Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Rechnen mit Datum und Uhrzeit
zurück: Summe-Formel gibt Wert nicht aus? weiter: Ganze Zeile per Dropdown-Feld einfügen... Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
ninihofmann
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Jun 2008, 09:35
Rufname:

Rechnen mit Datum und Uhrzeit - Rechnen mit Datum und Uhrzeit

Nach oben
       Version: Office 2003

Hallo,

für statistische Zwecke muss ich Soll-Ankunftszeiten mit Ist-Ankunftszeiten vergleichen.

Soll Ist Diff Tage Diff Stunden
25.5.2008 10:00:00 25.5.2008 17:00:00 0,00
26.5.2008 18:00:00 27.5.2008 10:00:00 1,00 8:00
27.5.2008 10:00:00 26.5.2008 15:00:00 -1,00 0:00

Die WENN-Funktion für die Differnez der Tage ist kein Problem und läuft einwandfrei. Nur die Differenz in Stunden, also Differenz Tage + Differnez Stunden = Gesamtdifferenz, macht Probleme.

=WENN(E12=0;D12-B12;WENN(E12<0;D14-B14+24;WENN(E12>0;B12-D12+24;FALSCH)))

Bin für jede Hilfe dankbar. Vielen Dank im Voraus.

LG, Nicole[/b]
CaBe
Word-Kenner und Excel-Anwender


Verfasst am:
19. Jun 2008, 10:18
Rufname: Carsten
Wohnort: Bremen


AW: Rechnen mit Datum und Uhrzeit - AW: Rechnen mit Datum und Uhrzeit

Nach oben
       Version: Office 2003

Hallo Nicole,

so richtig schlau bin ich nicht aus deiner Aussage geworden:
Zitat:
Nur die Differenz in Stunden, also Differenz Tage + Differnez Stunden = Gesamtdifferenz, macht Probleme.

Laut deiner "Tabelle" gibt es die Spalte Gesamtdifferenz gar nicht. Hingegen hast du Tage und Stunden separat betrachtet. Wie soll die Gesamtdifferenz denn dargestellt werden? Bisher habe ich mal nur nachgebaut:
Tabelle1

 ABCDEF
1Soll DatumSoll StundeIst DatumIst StundeDiff TageDiff Stunden
225.05.200810:00:0025.05.200817:00:0007:00
326.05.200818:00:0027.05.200810:00:0018:00
427.05.200810:00:0026.05.200815:00:00-15:00

Formeln der Tabelle
ZelleFormel
E2=C2-A2
F2=WENN(E2=0;D2-B2;WENN(E2<0;D2-B2+24;WENN(E2>0;B2-D2+24;FALSCH)))
E3=C3-A3
F3=WENN(E3=0;D3-B3;WENN(E3<0;D3-B3+24;WENN(E3>0;B3-D3+24;FALSCH)))
E4=C4-A4
F4=WENN(E4=0;D4-B4;WENN(E4<0;D4-B4+24;WENN(E4>0;B4-D4+24;FALSCH)))


Excel Jeanie Html

_________________
Freundlichst,
Carsten

Keine Antwort wäre wirklich schade!
ninihofmann
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Jun 2008, 10:23
Rufname:

AW: Rechnen mit Datum und Uhrzeit - AW: Rechnen mit Datum und Uhrzeit

Nach oben
       Version: Office 2003

Hi,

danke für deine schnelle Hilfe.

Die Differenz Stunden soll die Gesamtdifferenz darstellen.

LG, Nicole
CaBe
Word-Kenner und Excel-Anwender


Verfasst am:
19. Jun 2008, 10:29
Rufname: Carsten
Wohnort: Bremen

AW: Rechnen mit Datum und Uhrzeit - AW: Rechnen mit Datum und Uhrzeit

Nach oben
       Version: Office 2003

Hallo Nicole,

nach Umschalten über Extras/Optionen..., Register 'Berechnung' "1904-Datumswerte" ist es möglich, auch negative Uhrzeiten anzuzeigen; also:
Tabelle1

 ABCDEFG
1Soll DatumSoll StundeIst DatumIst StundeDiff TageDiff StundenDiff Gesamt
226.05.201210:00:0026.05.201217:00:0007:007:00
327.05.201218:00:0028.05.201210:00:0018:0016:00
428.05.201210:00:0027.05.201215:00:00-15:00-19:00

Formeln der Tabelle
ZelleFormel
E2=C2-A2
F2=WENN(E2=0;D2-B2;WENN(E2<0;D2-B2+24;WENN(E2>0;B2-D2+24;FALSCH)))
G2=E2*24+(D2-B2)
E3=C3-A3
F3=WENN(E3=0;D3-B3;WENN(E3<0;D3-B3+24;WENN(E3>0;B3-D3+24;FALSCH)))
G3=E3*24+(D3-B3)
E4=C4-A4
F4=WENN(E4=0;D4-B4;WENN(E4<0;D4-B4+24;WENN(E4>0;B4-D4+24;FALSCH)))
G4=E4*24+(D4-B4)


Excel Jeanie Html

_________________
Freundlichst,
Carsten

Keine Antwort wäre wirklich schade!
ninihofmann
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Jun 2008, 11:06
Rufname:


AW: Rechnen mit Datum und Uhrzeit - AW: Rechnen mit Datum und Uhrzeit

Nach oben
       Version: Office 2003

Hallo Carsten,

es funktioniert!!! Ich sitze immer wieder vor der Kiste und staune!
Herzlichen Dank.

Liebe Grüße, Nicole
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Datum in Excel Tabelle in Tagen darstellen 2 Unregistered 5101 22. März 2005, 20:49
Gast Datum in Excel Tabelle in Tagen darstellen
Keine neuen Beiträge Excel Formeln: Wenn Datum fast erreicht, Feld Rot 9 JörgK. 2957 21. März 2005, 16:29
JörgK. Wenn Datum fast erreicht, Feld Rot
Keine neuen Beiträge Excel Formeln: Datum in Zelle aktualisieren 2 Gast 1436 07. März 2005, 00:43
ae Datum in Zelle aktualisieren
Keine neuen Beiträge Excel Formeln: Datum rot anzeigen 2 Mimoss 2046 15. Feb 2005, 23:07
AnBo Datum rot anzeigen
Keine neuen Beiträge Excel Formeln: zellwert 2-stellig anzeigen - eingabe + rechnen 5-stellig 5 strandexpress 1207 22. Jan 2005, 15:35
Arnim zellwert 2-stellig anzeigen - eingabe + rechnen 5-stellig
Keine neuen Beiträge Excel Formeln: 8-stellige Zahl in Datum umwandeln 1 Controller1976 4207 14. Jan 2005, 12:35
ae 8-stellige Zahl in Datum umwandeln
Keine neuen Beiträge Excel Formeln: Datum aus mehreren Zellen zusammensetzen. 9 gast2005 5086 25. Dez 2004, 22:33
Kuwe Datum aus mehreren Zellen zusammensetzen.
Keine neuen Beiträge Excel Formeln: Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft 7 Tristan68 1841 25. Nov 2004, 19:48
Arnim Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft
Keine neuen Beiträge Excel Formeln: Datum 1 Peter3 2568 16. Okt 2004, 21:51
ae Datum
Keine neuen Beiträge Excel Formeln: Datum als Wochentag automatisch darstellen? 6 Gast 1432 05. Okt 2004, 17:11
gast Datum als Wochentag automatisch darstellen?
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung auf Datum beziehen ? 8 Gast 2449 29. Sep 2004, 22:53
MichaelP Bedingte Formatierung auf Datum beziehen ?
Keine neuen Beiträge Excel Formeln: verketten mit Datum (Format übernehmen) 2 etom2000 3560 20. Aug 2004, 10:20
etom2000 verketten mit Datum (Format übernehmen)
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Web Editor Forum