Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Dropdown Auswahl, anschließend Inhalte kopieren.
zurück: Excel VBA - Text fortlaufend einfügen Problem weiter: getopenfilename mit variablen? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Naka
Gast


Verfasst am:
24. Apr 2008, 21:44
Rufname:

Dropdown Auswahl, anschließend Inhalte kopieren. - Dropdown Auswahl, anschließend Inhalte kopieren.

Nach oben
       Version: Office 2003

Also ich habe folgendes Situation:

- Ich habe in meiner Tabelle ab Zeile 100 (oder tiefer) eine Liste, in denen ich diverse Sachen speicher, das heißt Name, Kosten, Dauer ect.
Stelle wir uns vor ich habe eine Liste mit Autos, deren Kosten, Reperaturkosten und anderen Daten.

Nun möchte ich am oberen Tabellenblatt eine Dropdown Auswahl machen, bei der ich das Auto auswähle was mich interessiert. Beispiel in A1. Wie ich das mache ist mir bewusst (Wobei ich dankbar wäre wenn mir jemand sagt wie ich das mache wenn ich die Daten in einem anderen Tabellenblatt habe).

Nun habe ich aber Folgendes Problem:
Wenn ich nun eins dieser Autos ausgesucht habe möchte ich, das er alle Daten zu dem Auto in die benachbarten Zellen kopiert.
Also ich suche z.B. einen Porsche aus der dann in A1 steht, möchte dann aber in den Feldern B1 - H1 die anderen Daten des Porsches vorfinden!


Kann mir dann jemand sagen wie ich das mache?
Heinz Schweigert
Gast


Verfasst am:
25. Apr 2008, 01:07
Rufname:

AW: Dropdown Auswahl, anschließend Inhalte kopieren. - AW: Dropdown Auswahl, anschließend Inhalte kopieren.

Nach oben
       Version: Office 2003

Hallo Naka

das geht mit ner Matrixformel. Dafür muss in jede Zelle die einen Wert ausgeben soll diese Matrixformel:
z.B. in die Zelle B1 diese:

{=SUMME(WENN((A100:A150)=A1;(B100:B150)))}

Zelle A1 steht dein Suchbegriff. Wenn Jetzt der Wert oder Name aus A1 sagen wir in Zelle A120 gefunden wird, dann gibt Dir die Zelle B1 den Wert aus B120. Wenn Du diese Formel verwendest, dann darfst Du die geschwungene Klammer am Anfang und Ende nicht schreiben. Du schreibst die Formel ganz normal und schliesst sie am Ende mit Strg+Shift+Enter

Oder eine andere Möglichkeit ist per SVERWEIS das Ergebnis ausgeben zu lassen:

=SVERWEIS(A1;A100:A150;2;0)

Dabei ist A1 wieder der Suchbegriff, A100:A150 der Bereich wo dieser Suchbegriff gesucht werden soll, die Zahl 2 ist die 2.Spalte wo das Ergebnis gesucht wird;0 ist Zahl 0 und bezeichnet die Suchtiefe (absolute Übereinstimmung). Auch die Formel gibt Dir das Ergebnis aus der Zelle rechts vom Treffer (also Spalte B/wie im obigen Bsp. zu Treffer A120, Ergebnis B120). Für Ergebnisse aus den weiteren Spalten musst Du entsprechend statt der 2 ne 3;4;5;usw eingeben

Ufff, war jetzt n bisschen verwirrend wahrscheinlich, aber probiers einfach aus...
Gruss Heinz
Naka
Gast


Verfasst am:
26. Apr 2008, 22:10
Rufname:


AW: Dropdown Auswahl, anschließend Inhalte kopieren. - AW: Dropdown Auswahl, anschließend Inhalte kopieren.

Nach oben
       Version: Office 2003

Danke dir, hab das auch mit SVerweis gemacht, hab Donnerstag Nacht noch ein Tutorial dazu gefunden und es mal umgesetzt - funktioniert wunderbar.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Hilfe! Zelleninhalte in andere Tabellen kopieren. 2 erdboy 1490 17. Sep 2005, 13:25
Gast Hilfe! Zelleninhalte in andere Tabellen kopieren.
Keine neuen Beiträge Excel Formeln: Relativer Zellbezug - Kopieren in andere Bereiche 5 Ralf123 1458 18. Aug 2005, 18:14
fridgenep Relativer Zellbezug - Kopieren in andere Bereiche
Keine neuen Beiträge Excel Formeln: Formaln kopieren/Absolute Zellen ersetzen DRINGEND! 2 Craig Marduk 1627 15. Aug 2005, 08:06
Craig Marduk Formaln kopieren/Absolute Zellen ersetzen DRINGEND!
Keine neuen Beiträge Excel Formeln: Auswahl eines Kombinationsfeldes in einer Formel verwenden 4 alex320 758 09. Aug 2005, 08:24
Gast Auswahl eines Kombinationsfeldes in einer Formel verwenden
Keine neuen Beiträge Excel Formeln: Formel kopieren ohne jede änder zu müssen - Lösung? 8 AxelCT 4813 13. Jul 2005, 14:37
AxelCT ausgeloggt Formel kopieren ohne jede änder zu müssen - Lösung?
Keine neuen Beiträge Excel Formeln: errechneten Wert aus Zelle kopieren? 2 Markus_H 1755 06. Jul 2005, 10:25
Markus_H errechneten Wert aus Zelle kopieren?
Keine neuen Beiträge Excel Formeln: Dropdown 5 qwertzuiop 1714 20. Jun 2005, 13:38
ae Dropdown
Keine neuen Beiträge Excel Formeln: Inhalte trennen 2 Gast 2454 17. Feb 2005, 14:09
Gast Inhalte trennen
Keine neuen Beiträge Excel Formeln: Verknüpfungen nach Kopieren eines Verzeichnises 17 Toledo 4274 12. Jan 2005, 10:27
Toledo Verknüpfungen nach Kopieren eines Verzeichnises
Keine neuen Beiträge Excel Formeln: Datensätze automatisch kopieren 2 Gast 2731 04. Jan 2005, 20:57
Gast Datensätze automatisch kopieren
Keine neuen Beiträge Excel Formeln: Zellinhalte KOPIEREN 5 hilfloses Wesen 1732 23. Dez 2004, 13:42
Gast Zellinhalte KOPIEREN
Keine neuen Beiträge Excel Formeln: Formeln anzeigen und Formeln mit Bezug kopieren 3 birgitrb 2270 01. Okt 2004, 16:22
Gast Formeln anzeigen und Formeln mit Bezug kopieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editoren Forum