Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Leeres Feld in Excel ignorieren
zurück: Noten rausfiltern weiter: Daten aus einzelnen Tabellenblättern zusammenführen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Nikiii
Gast


Verfasst am:
20. März 2008, 19:11
Rufname:

Leeres Feld in Excel ignorieren - Leeres Feld in Excel ignorieren

Nach oben
       Version: (keine Angabe möglich)

Hallo,
Ich versuche schon seit 2 Tagen eine Formel für meine Facharbeit zu finden, mit der ich berechnen kann, wieviele Monate ich im laufendem Jahr abschreiben muss.
Die Formel sieht bisher wie folgt aus:

=WENN(L11-C4>12;12;WENN(L11-C4=0;"";L11-C4))

L11 = Gesamte Nutzungsdauer in Monaten

C4 = 13-M6 (M6=Anschaffungsdatum), also die Monate die ich im ersten Jahr
abschreiben muss

Das ganze funktioniert auch soweit, nur hab ich das Problem das wenn ich weniger als
6 Jahre (Die Tabelle kann bisher nur eine 6 Jahres AfA berechne) abschreibe,
also zum Beispiel 2 Jahre, in Kästchen C8 "#WERT!" erscheint.

Die Formel aus C8 sieht so aus:

=WENN(L11-C4-C5-C6-C7>12;12;WENN(L11-C4-C5-C6-C7=0;"";L11-C4-C5-C6-C7))

Der Fehler kommt wie ich mir denke daher, dass bei 2 Jahren AfA C7 nun leer ist und er es nun nicht mehr berechnen kann.

Meine Frage ist also mit anderen Worten: Kann ich der Formel irgendwie sagen, dass er C7 nicht mit berechnen soll wenn es leer ist, also keine Monatszahl drinnen steht ?

Hoffe hier blickt jemand durch.. ziemliches durcheinander.
Wäre euch sehr dankbar wenn ihr eine Lösung wisst!

Niki
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
21. März 2008, 16:56
Rufname:
Wohnort: Oldenburg i.O.


AW: Leeres Feld in Excel ignorieren - AW: Leeres Feld in Excel ignorieren

Nach oben
       Version: (keine Angabe möglich)

Hi,

nicht so konkret auf Deine Frage bezogen - aber vielleicht hilft Dir dies doch auf irgendeinen Pfad... Siehe Bild (Browser ggf. aktualisieren). Formel für E2, nach rechts unten unten kopieren
Code:
=WAHL(($A2>E$1)+2*($A2=E$1)+3*($A2<E$1);0;WENN($D2<=410;$D2;(13-$B2)*$D2/$C2);WENN($D2<=410;0;(MAX(0;MIN(12;$C2-(E$1-$A2-1)*12-13+$B2)))*$D2/$C2))

_________________
urs grüßt



Abschreibung.JPG
 Beschreibung:
 Dateigröße:  15.95 KB
 Angeschaut:  1371 mal

Abschreibung.JPG


Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: wo befindet sich im excel 07 das dropdown feld 4 guest 20312 05. Jun 2007, 08:47
ae wo befindet sich im excel 07 das dropdown feld
Keine neuen Beiträge Excel Formeln: Statistische Formeln: Nullwerte und Fehlerwerte ignorieren 2 AlexandraB 1093 03. Mai 2007, 11:39
AlexandraB Statistische Formeln: Nullwerte und Fehlerwerte ignorieren
Keine neuen Beiträge Excel Formeln: Angeklicktes Feld übertragen.... 5 Peter24 583 09. Apr 2007, 22:43
Gast Angeklicktes Feld übertragen....
Keine neuen Beiträge Excel Formeln: Feld automatisch ausfüllen 3 Gast 704 14. Feb 2007, 12:22
tom_r Feld automatisch ausfüllen
Keine neuen Beiträge Excel Formeln: 2 Formeln in einem Feld, geht das?? 5 Gast 601 01. Feb 2007, 10:55
urs 2 Formeln in einem Feld, geht das??
Keine neuen Beiträge Excel Formeln: wenn keine Eingabe, dann leeres Feld. Wie geht das? 2 Saarländerin 1605 31. Jan 2007, 11:41
Saarländerin wenn keine Eingabe, dann leeres Feld. Wie geht das?
Keine neuen Beiträge Excel Formeln: Leeres Feld erzeugen 2 mokona.s 602 10. Jan 2007, 11:38
mokona.s Leeres Feld erzeugen
Keine neuen Beiträge Excel Formeln: Runden auf CHF 0.05 genau und 2 Formel in einem Feld? 2 Birchmeier 11776 09. Aug 2006, 16:14
Birchmeier Runden auf CHF 0.05 genau und 2 Formel in einem Feld?
Keine neuen Beiträge Excel Formeln: HILFE: Addition mit #WERT! -Feld wiegeht das ??? 1 Gast 786 09. Jun 2006, 13:45
ae HILFE:  Addition mit #WERT! -Feld wiegeht das ???
Keine neuen Beiträge Excel Formeln: Sonntage ignorieren 3 HellHanson 495 05. Jun 2006, 15:45
rlenz Sonntage ignorieren
Keine neuen Beiträge Excel Formeln: Artikelnummern Endung mit H soll in eigenem Feld erscheinen 6 KrossSurfer 703 06. März 2006, 10:50
Gast Artikelnummern Endung mit H soll in eigenem Feld erscheinen
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Wenn...dann...Bedingungsfeld - Feld ausblenden 3 Gast 1083 26. Jan 2006, 15:31
ae Wenn...dann...Bedingungsfeld - Feld ausblenden
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web Forum