Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Excel Problem!!! Funktion aber wie???
zurück: SUMMEWENN mit mehreren Kriterien weiter: fehlermeldung #wert! und automatische zellenerweiterung Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Elm...
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Okt 2004, 13:59
Rufname:

Excel Problem!!! Funktion aber wie??? - Excel Problem!!! Funktion aber wie???

Nach oben
       

Hallo, hab nen kleines Problem... also ich will mir ne Excel Tabelle für mein Zollstock Archiv anlegen, diese liegen in verschieden Karton, also muß die Excel Tabelle "alphabetisch" sein, mit einer Spalte "laufende Nummer", damit ich immer weis wieviele ich gerade habe, und eine Spalte "Karton", damit ich weiß in welchen der Zollstock liegt...


lfd. Nr. | Beschreibung | Karton
---------|--------------|--------
...........| A.............. |.............
...1...... | xyz.......... |... .1......
...2...... | bca.......... |.... 2......
............|................ |..............
............| B............. |..............
...3...... | nmd......... | ....1.......


So ungefähr soll die Tabelle aussehn! Das heißt wenn in der Spalte "Karton nichts eingetragen ist, soll auch in der Spalte "lfd. Nr." kein Eintrag sein!

Gibt es da irgend ne Funktion womit ich die komplette Spalte "lfd.Nr." formatieren kann, damit das dann so aussieht... Hoffe doch... Surprised)

Danke schon mal für eure Hilfe!!!

Elm...

PS Sorry das die Tabelle, hier nen bissel doof aussieht, die senkrechten Striche sollen die Spalten markieren!
Gast



Verfasst am:
28. Okt 2004, 20:05
Rufname:


AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

nicht schon aber selten:

formel:
=WENN(C2<>0;A1+1;A1)

c = Karton
a = lfd.nr
zeile 1: a1 = 0

workaround
extras -> bedingte Formatierung
zielwert von zelle (z.b.) A1 = A0 -> schriftfarbe = tabellenhintergrundfarbe.

so steht zwar in jeder lfd. nr eine zahl, aber bei wiederholungen ist diese "unsichtbar"

getestet mit excel 2000
Kuwe
Excel-Anwender mit VBA


Verfasst am:
28. Okt 2004, 20:13
Rufname: Uwe

AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Hallo Elmar,

meinst Du das so?

 
 ABCDE
1     
2 lfdNrBeschreibungKarton 
3     
4 1A  
5 2xyz1 
6 3bca2 
7     
8 4B  
9 5nmd1 
10     
Formeln der Tabelle
B4 : =WENN(LÄNGE(C4)>0;MAX(B$3:B3)+1;"")
B5 : =WENN(LÄNGE(C5)>0;MAX(B$3:B4)+1;"")
B6 : =WENN(LÄNGE(C6)>0;MAX(B$3:B5)+1;"")
B7 : =WENN(LÄNGE(C7)>0;MAX(B$3:B6)+1;"")
B8 : =WENN(LÄNGE(C8)>0;MAX(B$3:B7)+1;"")
B9 : =WENN(LÄNGE(C9)>0;MAX(B$3:B8)+1;"")
 


_________________
Gruß Uwe
Gast



Verfasst am:
28. Okt 2004, 22:52
Rufname:

AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Ein anderer Lösungsansatz:
Formel in Zelle b4 (gemäss Tabellenmuster Uwe):
=wenn(d4="";"";anzahl2(d$4:d4))
Formel bis b8 hinunterkopieren.
Die Funktion anzahl2(..) kann durch anzahl(..) ersetzt werden, wenn in der Spalte d ausschliesslich Werte stehen.
Elm...
Im Profil kannst Du frei den Rang ändern


Verfasst am:
29. Okt 2004, 09:42
Rufname:


AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Danke erst mal für Eure Lösungen, Uwes kommt der Sache am nähsten... Nur hab ich das problem...
Was bei Uwe "C4" und bei beschreibung drin steht, soll kein Datensatz sein, sondern eher ne Markierung fürs Alphabet... also darf die Zelle a keine lfd. Nummer bekommen, und somit steht da die laufenden nummern immer doppelt drinne...

Und noch was wenn ich jetzt neue Datenhinzufügen will, und die aus ner anderen tabelle hineinkopieren möchte, muß ich da immer erst soviele Zeilen neu erzeugen, oder gibt es ne Einstellung dam it die anderen zellen die bestehn, automatisch nach unten rutschen???

Danke nochmals...
Gast



Verfasst am:
29. Okt 2004, 11:20
Rufname:

AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Hast du den Lösungsansatz
=wenn(d4="";"";anzahl2(d$4:d4))
getestet?
Er löst das von dir bemängelte Problem bei b1 und kann erst noch unbeschränkt nach unten kopiert werden, sodass auch neue Daten eingefügt werden können.
Gast



Verfasst am:
29. Okt 2004, 11:22
Rufname:

AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Sorry, gemeint war natürlich das Problem bei b4
Gast



Verfasst am:
29. Okt 2004, 12:21
Rufname:

AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

Super @ gast, das is echt genial, die Lösung passt!!! Danke...

Jetzt muß ich nur noch hinbekommen das ich Zellen oder besser Zeilen einfügen kann und es die anderen einfach nach unter verschiebt, hat da noch jemand ne Möglichkeit...

Thx
haarald
gewöhnlicher Excel Nutzer


Verfasst am:
29. Okt 2004, 13:23
Rufname:
Wohnort: Wien


AW: Excel Problem!!! Funktion aber wie??? - AW: Excel Problem!!! Funktion aber wie???

Nach oben
       

ich denke,
du kannst eine befüllte Zeile markieren und mit der rechten Maustaste an der einzufügenden Position "Kopierte Zellen einfügen" wählen und diese dann mit den neuen Werten füllen...
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Funktion mit zwei Bedingungen und drei Bedingungen! 2 Gossi 5531 23. Jun 2005, 16:17
Arnim Funktion mit zwei Bedingungen und drei Bedingungen!
Keine neuen Beiträge Excel Formeln: "Ersetzen"-Funktion innerhalb von Formeln? 1 oko 537 20. Jun 2005, 17:13
Thomas Ramel "Ersetzen"-Funktion innerhalb von Formeln?
Keine neuen Beiträge Excel Formeln: =Otto.xls!Otto1 als Funktion - aber wie? 9 Zahlenheinz 903 17. Jun 2005, 10:56
frankkubiak =Otto.xls!Otto1 als Funktion - aber wie?
Keine neuen Beiträge Excel Formeln: WAHL Funktion 11 Chayno 4388 25. Mai 2005, 12:56
ae WAHL Funktion
Keine neuen Beiträge Excel Formeln: Funktion "SUCHEN" 2 Claudia36 1462 19. Mai 2005, 17:18
Claudia36 Funktion "SUCHEN"
Keine neuen Beiträge Excel Formeln: Funktion zusammenbauen 34 Aloha 5201 01. Apr 2005, 15:51
Aloha Funktion zusammenbauen
Keine neuen Beiträge Excel Formeln: Wahl funktion und ihr sinn 3 Gast 7378 14. März 2005, 15:23
fridgenep Wahl funktion und ihr sinn
Keine neuen Beiträge Excel Formeln: Funktion zum autom. Einblenden einer Gruppierung? 2 original-m 820 28. Feb 2005, 19:11
original-m Funktion zum autom. Einblenden einer Gruppierung?
Keine neuen Beiträge Excel Formeln: MID Funktion 2 filomen 944 03. Jan 2005, 17:02
filomen MID Funktion
Keine neuen Beiträge Excel Formeln: Benutzerdefinierte Funktion 1 Ottrick 2471 15. Dez 2004, 18:18
Robsl Benutzerdefinierte Funktion
Keine neuen Beiträge Excel Formeln: Verknüpfung mit ATPVBAEN.XLA / Eomonth Funktion 3 loisl04 5162 11. Dez 2004, 08:29
Thomas Ramel Verknüpfung mit ATPVBAEN.XLA / Eomonth Funktion
Keine neuen Beiträge Excel Formeln: fortlaufende zahl in spalte - funktion? 2 lifius 1742 10. Dez 2004, 19:45
lifius fortlaufende zahl in spalte - funktion?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project