Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Dienstplan mit Datenbank-Charakter erstellen
Gehe zu Seite 1, 2, 3  Weiter
zurück: Dynamsich einen Zellenbereich mit Inhalt füllen weiter: Schaltjahr berechnen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 15:01
Rufname:
Wohnort: CH

Dienstplan mit Datenbank-Charakter erstellen - Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo zusammen.

Ich bin heute durch Zufall auf dieses Forum gestossen und total "aus dem Häuschen" dass es sowas gibt. Seid langer Zeit möchte ich so oft etwas mit dem Excel machen, habe aber, im Gegensatz zu den meisten anderen Programmen, mit diesem sehr grosse Probleme, bis ich etwas begreife.

Nun hoffe ich natürlich, hier Hilfe zu bekommen. Wenn ich andernorts solche selber geben kann, mach' ich das natürlich von Herzen gerne! Very Happy

Nun meine aktuelle Frage (über die Suchfunktion habe ich keine Antwort darauf gefunden):

Ich habe einen neuen Job, bei dem ich unregelmässig arbeite und möchte gerne eine Dienstplan-Tabelle erstellen, um jeden Monat meinen persönlichen Plan "für an den Kühlschrank" ausdrucken zu können.

Mein Wunsch wäre, z.B. in "Tabelle2 Spalte A" die Dienstnummern einzugeben und in "Spalte B" die dazugehörigen Zeiten, so dass wenn ich in "Tabelle1 (Haupttabelle) Spalte A" die Dienstnummer eingebe, in Spalte B die Zeiten automatisch übernommen werden. So dass eine Art die Dienst-Zeiten im Hintergrund gespeichert sind und diese zu den Dienstnummern "zugeordnet" sind. Wisst Ihr was ich meine...? Confused

Entschuldigt, dass ich einige Fachausdrücke nicht kenne und es ein Bisschen umschreiben muss... Wenn nicht klar ist was ich meine, bitte nachfragen! Very Happy

Vielen Dank für Eure Hilfe...

Gruss
Johannes
ae
Mein Name ist Ente


Verfasst am:
26. Sep 2004, 15:11
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo,
ich habe das ganze der Übersicht halber in1 Tabelle gemacht - du kannst die Hilfstabelle aber auslagern !
Die Spalten D und E sind als Uhrzeit formatiert.
Wenn Du in spalte B eine Zahl von 1 - 3 eingibst berechnet Excel welcher Dienst es ist und von wann bis wann.
Die Auswahl der Dienste in Spalte B könnte man noch über ein dropdown mit Daten Gültigkeit Liste vereinfachen.

Tabelle3
 ABCDE
1Hilfstabelle    
21Fruehdienst06:0014:00 
32Spaetdienst14:0022:00 
43Nachtdienst22:0006:00 
5     
6     
7     
8DatumDienstDienstartvonbis
901.10.20041Fruehdienst06:0014:00
1002.10.20041Fruehdienst06:0014:00
1103.10.20042Spaetdienst14:0022:00
1204.10.20042Spaetdienst14:0022:00
1305.10.20043Nachtdienst22:0006:00
1406.10.20041Fruehdienst06:0014:00
1507.10.20043Nachtdienst22:0006:00
Formeln der Tabelle
C9 : =SVERWEIS(B9;$A$2:$D$4;2;FALSCH)
D9 : =SVERWEIS(B9;$A$2:$D$4;3;FALSCH)
E9 : =SVERWEIS(B9;$A$2:$D$4;4;FALSCH)
C10 : =SVERWEIS(B10;$A$2:$D$4;2;FALSCH)
D10 : =SVERWEIS(B10;$A$2:$D$4;3;FALSCH)
E10 : =SVERWEIS(B10;$A$2:$D$4;4;FALSCH)
C11 : =SVERWEIS(B11;$A$2:$D$4;2;FALSCH)
D11 : =SVERWEIS(B11;$A$2:$D$4;3;FALSCH)
E11 : =SVERWEIS(B11;$A$2:$D$4;4;FALSCH)
C12 : =SVERWEIS(B12;$A$2:$D$4;2;FALSCH)
D12 : =SVERWEIS(B12;$A$2:$D$4;3;FALSCH)
E12 : =SVERWEIS(B12;$A$2:$D$4;4;FALSCH)
C13 : =SVERWEIS(B13;$A$2:$D$4;2;FALSCH)
D13 : =SVERWEIS(B13;$A$2:$D$4;3;FALSCH)
E13 : =SVERWEIS(B13;$A$2:$D$4;4;FALSCH)
C14 : =SVERWEIS(B14;$A$2:$D$4;2;FALSCH)
D14 : =SVERWEIS(B14;$A$2:$D$4;3;FALSCH)
E14 : =SVERWEIS(B14;$A$2:$D$4;4;FALSCH)
C15 : =SVERWEIS(B15;$A$2:$D$4;2;FALSCH)
D15 : =SVERWEIS(B15;$A$2:$D$4;3;FALSCH)
E15 : =SVERWEIS(B15;$A$2:$D$4;4;FALSCH)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
26. Sep 2004, 15:41
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Johannes -
ich habe dir das ganze mal in 2 Tabellen aufgeteilt und mit dem Dropdown als Beispieldatei abgestellt.

http://www.skripteundaufgaben.de/dienste.xls

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 16:59
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Andreas.

Erst einmal - herzlichen Dank für die schnelle und aufwändigen Antworten, einfach spitze!

Nun habe ich in der Tabelle2 alle meine Dienste erfasst und wollte in der Tabelle1 die "Gültigkeitsformel" anwenden. Das Programm beschwerte sich natürlich dann, "Dienste" sei ein unbekannter Bereich.

1. Wie bezeichne in Tab.2 die Spalte A als "Dienste"?

2. Wie verbinde ich die Dienstnummern mit den Spalten B, C, D und E, in denen ich die Anfangs- und Endzeiten der jeweils zwei Dienstteile habe? Muss ich jedes Feld einzeln verweisen? Ich muss dem Programm doch irgendwie beibringen, dass die ganze Zeile zusammenhängt...? Question

3. Was heisst/ist "dropdown"?

Danke und Gruss
Johannes
ae
Mein Name ist Ente


Verfasst am:
26. Sep 2004, 17:04
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Johannes,

zu 1.

Gehe in die Tabelle mit denUrsprungsdaten markiere dort die Werte in meinem Bsp. von A2 bis A4 - dann menüleiste einfügen Name und dort vergib den Namen Dienste-

zu3. das dropdown ist nix anderes als das über daten Gültigkeit Liste erzeugte Pfeilchen das in einer Liste dir vorgegebene Auswahlelemente gibt.

zu 2.
ups das versteh ich nicht ganz was du da meinst !
in meiner datei die ich zum download gestellt habe schreibst du die Formeln nur jeweisl in die Zellen C2, D2 undE2 und ziehst diese nach unten. Oder wie war dieser Teil deiner Frage zu verstehen ?

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 17:11
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Andreas.

Super, das mit "Dienste" hat funktioniert

Bei Nr. 2. meinte ich genau das, was jetzt ausgeblieben ist. Ich habe nun in der Spalte Dienste ein "dropdown" Very Happy , welches alle meine Dienste beinhaltet. Wenn ich nun einen davon Auswähle, bleibt aber rechts davon, bei den Anfangs- und Feierabendzeiten - natürlich - alles leer. Muss ich diese "sverweise", die für mich zugegeben im Moment noch ziemlich chinesisch wirken, alle manuel eingeben...? In jedes Feld einzeln? Shock Wenn ja, wie sage ich ihm, dass sich der Verweis auf die Tabelle2 bezieht...?`

Vielen Dank
Gruss Johannes
ae
Mein Name ist Ente


Verfasst am:
26. Sep 2004, 17:24
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Johannes,

das geht recht einfach.
Du schreibst in die erste Zelle, wo zB die Arbeitsbeginnzeit stehen soll

=Sverweis(

nun klickst links daneben auf die Zelle
dann ein Semikolon,
jetzt wechsle in die Tabelle 2 - markiere den Bereich mit den Daten und drücke danach die F4 Taste das es absolute Bezüge werden. Nun wieder ein semikolon und schreib die Zahl rein in welcher Spalte sich der gesuchte wert befindet -
noch ein semikolon und das Wort falsch und die KLammer zumachen.
Enter
Jetzt kannst die Formel nach unten kopieren - so gehst in den anderen Spalten auch vor.

Wenns nicht klappt melde dich einfach nochmals

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 18:01
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Andreas.

Funktioniert leider gar nicht richtig... Habe es zwar genau so gemacht, aber ich habe die Dienstnummern ja nirgends mit den dazugehörigen Zeiten kombiniert. Somit erscheint jetzt in der Spalte des Dienstbeginns des 1. Teils überall #NV und ändert sich mit der Auswahl eines Dienstes nicht.

In meinem Fall ist dies die Spalte C, in der Spalte D wäre das 1. Dienstende. Die Zeichenfolge in Spalte C, es steht aber:

=SVERWEIS(D3;'Tabelle2'!$A$3:$E$20;'Tabelle2'!B:B;FALSCH)

Warum D in C...?

Bei mir ist:
Spalte A: Datum
Spalte B: Dienstnummer
Spalte C: Dienstbeginn 1. Teil
Spalte D: Dienstende 1. Teil
Spalte E: Dienstbeginn 2. Teil
Spalte F: Dienstende 2. Teil

In Tabelle2 ist alles um eine nach links verschoben, da ja dort kein Datum sein muss.

Danke!

Gruss
Johannes
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 18:16
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Jetzt hat sich etwas getan...

Aus D habe ich B gemacht, nun steht, nach dem ich bei B ein Dienst gewählt habe, #Wert! im Feld, vielleicht schaff' ich es noch! Smile

Gruss Johannes
ae
Mein Name ist Ente


Verfasst am:
26. Sep 2004, 18:30
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Johannes,

Code:
=SVERWEIS(D3;'Tabelle2'!$A$3:$E$20;'Tabelle2'!B:B;FALSCH)


diese Formel stimmt so nicht ganz - statt des Teils 'Tabelle2'!B:B schreib einfach eine 2 für die 2. Spalte des Suchbereichs (Matrix). Dann müsste es passen -
Excel will da in der Schreibweise eine Zahl für die Spalte - wobei da einfach durchgezählt wird.

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 18:37
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Andreas.

WOW, super, hat funktioniert!

VIELEN, vielen Dank!!!

Noch eine kleine Frage zum Schluss. Ist es zur "optischen Kosmetik" möglich, das #NV etc. auszublenden, so dass das Feld einfach leer ist, wenn keine Zelle verwiesen ist, so z.B. an den Freitagen?

Vielen Dank, bin begeistert! Very Happy
Gruss Johannes
fl618
Gibt sich Mühe


Verfasst am:
26. Sep 2004, 18:44
Rufname:
Wohnort: Wallbach, CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Johannes

Sieh Dir mal Andreas' Tip an:
http://www.office-loesung.de/viewtopic.php?t=16428

_________________
Ciao
Franz

--------------------------------------------
(da ich eine engl. Excel Version verwende, kann es vorkommen, dass ich leider nicht immer die richtige deutsche Übersetzung erwische ...)
swissbird
Grundkenntnisse


Verfasst am:
26. Sep 2004, 19:47
Rufname:
Wohnort: CH

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo Franz.

Und auch das hat zu guter Letzt noch funktioniert, vielen Dank! Very Happy

Schönen Abend
Gruss Johannes
Gast



Verfasst am:
17. Dez 2004, 10:50
Rufname:

AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo zusammen.

Ich hole dieses alte Thema wieder hervor... Razz

- Wie lautet der Befehl, wenn ich der Tabelle sagen möchte, dass sie in einem Feld, dass kein Resultat beinhaltet, nicht "#NV" anzeigen soll, sondern eben nicht?

- Zudem möchte ich noch jedem Dienst eine Handy-Nummer zuteilen. Nun gibt es Dienste, zu denen eine Handy-Nummer gehört, wie aber auch solche, zu denen zwei gehören. Ich weiss, etwas kompliziert, aber is' einfach so. Very Happy Kann ich nun die Spalte mit den Handynummern in der Höhe "halbieren", so dass ich entweder diese eine Nummer einfach reinschreiben kann, und wenn es aber deren zwei sind, diese beide, etwas kleiner, untereinander eintragen?

Viele Grüsse und besten Dank!

Johannes
ae
Mein Name ist Ente


Verfasst am:
17. Dez 2004, 10:55
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Dienstplan mit Datenbank-Charakter erstellen - AW: Dienstplan mit Datenbank-Charakter erstellen

Nach oben
       

Hallo,

zu der Fehlermeldung --

Code:
=wenn(istfehler(DeineFormel);"";DeineFormel)


Zum2. Teil deiner Frage habe ich leider auchkeine rechte Idee - am besten postest das ganze als separaten neuen Thread bevor es hier im alten untergeht.

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2, 3  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 3
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Liste erstellen ohne bestimmte Werte 6 st@ni 1947 20. Sep 2006, 13:53
st@ni Liste erstellen ohne bestimmte Werte
Keine neuen Beiträge Excel Formeln: Urlaubsplan erstellen 2 Nicole_77 8701 14. Sep 2006, 13:12
< Peter > Urlaubsplan erstellen
Keine neuen Beiträge Excel Formeln: Erstellen einer Auswertungstabelle für Fussballspiele 1 darkface 1438 08. Sep 2006, 20:32
Hübi Erstellen einer Auswertungstabelle für Fussballspiele
Keine neuen Beiträge Excel Formeln: automatisches x erstellen 4 MRBoy1998 703 08. Sep 2006, 14:48
ae automatisches x erstellen
Keine neuen Beiträge Excel Formeln: Diagramm erstellen, dass sich auf mehrere Blätter einer Date 1 annaringe 5667 04. Jul 2006, 15:00
Alto Diagramm erstellen, dass sich auf mehrere Blätter einer Date
Keine neuen Beiträge Excel Formeln: Dienstplan in Excel 7 cristor 13849 10. Mai 2006, 10:03
cristor Dienstplan in Excel
Keine neuen Beiträge Excel Formeln: Rechnungsnummer aus Datum erstellen 1 konzZzumi 2725 02. Mai 2006, 15:54
< Peter > Rechnungsnummer aus Datum erstellen
Keine neuen Beiträge Excel Formeln: Projektplan erstellen ohne Diagramm nutzen zu müssen 2 BK 14140 10. Apr 2006, 21:23
Gast Projektplan erstellen ohne Diagramm nutzen zu müssen
Keine neuen Beiträge Excel Formeln: Aus einer Rangliste eine geordnete rangliste erstellen 7 Tutzi76 16794 21. März 2006, 17:08
ae Aus einer Rangliste eine geordnete rangliste erstellen
Keine neuen Beiträge Excel Formeln: Dienstplan mit Stundenabrechnung 5 PhReAkAzOiD 8587 15. Dez 2005, 13:43
PhReAkAzOiD Dienstplan mit Stundenabrechnung
Keine neuen Beiträge Excel Formeln: Mittels 2 Tabellen eine Übersicht erstellen 11 atwin97 1305 05. Okt 2005, 09:55
atwin97 Mittels 2 Tabellen eine Übersicht erstellen
Keine neuen Beiträge Excel Formeln: Erstellen von Datenblatt aus Tabellenzeile möglich? 5 harti986 1296 22. Sep 2005, 15:23
ae Erstellen von Datenblatt aus Tabellenzeile möglich?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Frontpage Forum