Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Formel für Rechnung
Gehe zu Seite 1, 2  Weiter
zurück: Wenn-Formel weiter: Excelverbindungen im Ordnern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
warsteiner
Gast


Verfasst am:
27. Aug 2004, 20:32
Rufname:

Formel für Rechnung - Formel für Rechnung

Nach oben
       

Hallo Gemeinde,
hab da mal ein Problem mit excel.
Ich möchte in einer Tabelle, an Hand des eingegebenen Datumzeitraums mir den Mietpreis sowie Gesamtmietbetrag errechnen lassen.
Die Eingaben sollen nur
B2 Mietanfang ;D2 Mietende;
erfolgen.

Zeitraum A13 bis B13 und C13 bis D13 = Mietpreis E13
Zeitraum A14 bis B14 und C14 bis D14 = Mietpreis E14
sonstige Zeitraum = Mietpreis E15

da es noch nicht kompliziert genug ist *haarerausreis*
soll der Mietbetrag in B3 (sollten alle Mietpreise) angegeben werden
die Mietdauer soll in D3 erscheinen
Mit dem Datumzeitraum komme ich einfach nicht mehr weiter.

Für Eure Hilfe wäre ich sehr dankbar. Und das ganze hätte ich gerne in einer Formel.

Danke schon mal im voraus für Euer Kopfzerbrechen

Uwe
ae
Mein Name ist Ente


Verfasst am:
27. Aug 2004, 20:56
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo Uwe,


schön wäre es etwas mehr über die Mietzeiträume zu wissen - ich denke das geht richtungSaisonpreise.
Ausserdem was ist wenn sich die Zeiträume überschneiden`???

Und noch eines vorab ----

Zitat:
Und das ganze hätte ich gerne in einer Formel.


Das würde ich mir abschminken - da wirst um hilfspalten wohl kaum herumkommen !

Aber um überhaupt mal konkret helfen zu können wäre es wichtig die paar mehr infos zu bekommen.

Zur Angabe deiner Mailaddy:

Hier gestellte Fragen sollten hier im Forum gelöst werden. Dies ist auch für andere mit ähnlichen Problemen wichtig und so können auch mehrere HelferInnen den aktuellen Stand mitbekommen.

Ich gehe mal davon aus das deine mailaddy keine Anfrage für eine Auftragsprogrammierung gegen Entgelt war -- Rolling Eyes Razz

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
warsteiner
Gast


Verfasst am:
27. Aug 2004, 22:12
Rufname:

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo Andreas,
mit meiner Email hatte ich wirklich nicht die Absicht, dass mir einer ein Angebot gegen Bezahlung macht. nee da setzte ich mich lieber noch mal 4!! Tage vor mein Excelbuch und reis mir die letzten Haare noch raus.

Ich kann die Tabelle hier nicht einfügen
Zitat:
Zeitraum A13 bis B13 und C13 bis D13 = Mietpreis E13

24.06.2004 - 31.08.2004 17.12.2004 - 03.01.2005 67€
Zitat:
Zeitraum A14 bis B14 und C14 bis D14 = Mietpreis E14

11.03.2005 - 03.04.2005 05.05.2005 - 29.05.2005 51€


Zitat:
Zeitraum A14 bis B14 und C14 bis D14 = Mietpreis E14

sonstige zeiten 41€

wenn sich Zeiten überschneiden sollen sie taggenau abgerechnet werde und alle unter D3 aufgeführt sein

Uwe
ae
Mein Name ist Ente


Verfasst am:
27. Aug 2004, 22:26
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Zitat:
nee da setzte ich mich lieber noch mal 4!! Tage vor mein Excelbuch und reis mir die letzten Haare noch raus.


Na wenn das mal für diese Aufgabenstellung ausreicht ! Razz

Also gut ,

Lass uns kleine schritte machen.

Zunächst mal habe ich die Tabelle aufgebaut -

Wenn ich das jetzt richtig verstanden habe, werden die Mietbeginn und Endewerte eingesetzt.
Jetzt wäre in meinem Bsp. so das für 4 Tage noch die 67 Euro und für die folgenden 17 Tage 41 Euro pro Tag berechnet werden sollen ?
Ist das so richtig ?

 
 ABCD
1ZeitraumvonbisPreis
2124.06.200431.08.200467
3217.12.200403.01.200567
4311.03.200503.04.200551
5405.05.200529.05.200551
65sonstige 41
7    
8    
9MietbeginnMietendePreis 
1028.08.200417.09.2004  
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
27. Aug 2004, 22:31
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hier das ganze schon mal mit einem Hilfsgerüst (Wie ich schon sagte - so mal eben in einer Formel fällt aus wegen is nich !)

Kannst du dem Konstrukt bis hier folgen ?

 
 ABCDEF
1ZeitraumvonbisPreis  
2124.06.200431.08.200467  
3217.12.200403.01.200567  
4311.03.200503.04.200551  
5405.05.200529.05.200551  
65sonstige 41  
7      
8      
9MietbeginnMietendePreisZeitraumTagePreis
1028.08.200417.09.200401 0
11   2 0
12   3 0
13   4 0
14   5 0
Formeln der Tabelle
C10 : =SUMME(F10:F14)
F10 : =WENN(E10&gt;0;SVERWEIS(D10;$A$2:$D$6;4;FALSCH)*E10;0)
F11 : =WENN(E11&gt;0;SVERWEIS(D11;$A$2:$D$6;4;FALSCH)*E11;0)
F12 : =WENN(E12&gt;0;SVERWEIS(D12;$A$2:$D$6;4;FALSCH)*E12;0)
F13 : =WENN(E13&gt;0;SVERWEIS(D13;$A$2:$D$6;4;FALSCH)*E13;0)
F14 : =WENN(E14&gt;0;SVERWEIS(D14;$A$2:$D$6;4;FALSCH)*E14;0)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
27. Aug 2004, 22:39
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Habe gerade mal für dich und evtl. "Mitbastler" den Standmeiner Tabelle abgestellt :

http://skripteundaufgaben.de/saison.xls

So siehts momentan aus - die Gesamttage sind ja easy zu ermitteln.
Die Formel für die Tage sonstiges ist auch klar - gesamt . summe aller ausser sonstige.

 
 ABCDEF
1ZeitraumvonbisPreis  
2124.06.200431.08.200467  
3217.12.200403.01.200567  
4311.03.200503.04.200551  
5405.05.200529.05.200551  
65sonstige 41  
7      
8      
9MietbeginnMietendePreisZeitraumTagePreis
1028.08.200417.09.20048611 0
11   2 0
12Tage Gesamt 213 0
13   4 0
14   521861
Formeln der Tabelle
C10 : =SUMME(F10:F14)
F10 : =WENN(E10&gt;0;SVERWEIS(D10;$A$2:$D$6;4;FALSCH)*E10;0)
F11 : =WENN(E11&gt;0;SVERWEIS(D11;$A$2:$D$6;4;FALSCH)*E11;0)
C12 : =B10-A10+1
F12 : =WENN(E12&gt;0;SVERWEIS(D12;$A$2:$D$6;4;FALSCH)*E12;0)
F13 : =WENN(E13&gt;0;SVERWEIS(D13;$A$2:$D$6;4;FALSCH)*E13;0)
E14 : =C12-SUMME(E10:E13)
F14 : =WENN(E14&gt;0;SVERWEIS(D14;$A$2:$D$6;4;FALSCH)*E14;0)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
warsteinerO5
Verstehe vom Excel soviel wie vom stricken


Verfasst am:
27. Aug 2004, 22:55
Rufname:

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Also das is ja wahnsinn wie schnell das geht.
Hab mich jetzt mal angemeldet.

Das mit dem folgen, naja ich verstehe schon einiges aber ich muss mir das schon in ruhe durch den Kopf gehen lassen.

Das ist für mich ungefähr wie lesen lernen Razz
Ein paar teile deiner Formel verstehe ich noch nicht E10> und so

Uwe
warsteinerO5
Verstehe vom Excel soviel wie vom stricken


Verfasst am:
27. Aug 2004, 23:04
Rufname:

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Sorry ich weiss immer noch nicht was da easy dran ist

Ich sitze hier seid Tagen und Du machst mal auf die schnelle

also Hut ab

Uwe
ae
Mein Name ist Ente


Verfasst am:
27. Aug 2004, 23:20
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo Uwe,

das war erst der anfang !

Bis hierher war es recht simpel-

schwer wird jetzt der abgriff für die Felder E10 bis E13
Hier muss nun ermittelt werden, wieviele Tage derGesamtzeit in den jeweiligen Bereich fallen.
Werde aber für heute erst mal schicht machen -
Sehe mir das morgen früh nochmals an -
Das E10 grösser 0 macht nix anders als zu schauen ob da schon ne Zahl drin steht - wenn ja holt sie sich den wert über sverweis mit dem multipliziert werden muss. wenn nein bleibt es 0


Oki,

dann bis morgen früh -

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
28. Aug 2004, 12:38
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo Uwe,

nach ein wenig basteln heute morgen die fertige Tabelle.

http://skripteundaufgaben.de/saison.xls

vielleicht kann ja mal der eine oder andere testen ob das so passt-
ich meine eigentlich ja , aber wer weiss..

 
 ABCDEF
1ZeitraumvonbisPreis  
2124.06.200431.08.200467  
3217.12.200403.01.200567  
4311.03.200503.04.200551  
5405.05.200529.05.200551  
65sonstige 41  
7      
8      
9MietbeginnMietendePreisZeitraumTagePreis
1028.08.200417.09.200493913201
11   200
12Tage Gesamt 21300
13   400
14   518738
15      
16<a href='http://www.skripteundaufgaben.de/' target='blank'>www.skripteundaufgaben.de</a>     
Formeln der Tabelle
C10 : =SUMME(F10:F14)
E10 : =MAX(;MIN($B$10+($A$10&gt;$B$10);MAX((B2&gt;C2);C2))-MAX(A10;B2))+MAX(;MIN(B10;MAX((B2&gt;C2);C2))-MAX(;B2))*($A$10&gt;$B$10)+MAX(;MIN($B$10+($A$10&gt;$B$10);MIN((B2&gt;C2);C2))-MAX($A$10;))+MIN($B$10;MIN((B2&gt;B1);C2))*($A$10&gt;$B$10)
F10 : =WENN(E10&gt;0;SVERWEIS(D10;$A$2:$D$6;4;FALSCH)*E10;0)
E11 : =MAX(;MIN($B$10+($A$10&gt;$B$10);MAX((B3&gt;C3);C3))-MAX(A11;B3))+MAX(;MIN(B11;MAX((B3&gt;C3);C3))-MAX(;B3))*($A$10&gt;$B$10)+MAX(;MIN($B$10+($A$10&gt;$B$10);MIN((B3&gt;C3);C3))-MAX($A$10;))+MIN($B$10;MIN((B3&gt;B2);C3))*($A$10&gt;$B$10)
F11 : =WENN(E11&gt;0;SVERWEIS(D11;$A$2:$D$6;4;FALSCH)*E11;0)
C12 : =B10-A10+1
E12 : =MAX(;MIN($B$10+($A$10&gt;$B$10);MAX((B4&gt;C4);C4))-MAX(A12;B4))+MAX(;MIN(B12;MAX((B4&gt;C4);C4))-MAX(;B4))*($A$10&gt;$B$10)+MAX(;MIN($B$10+($A$10&gt;$B$10);MIN((B4&gt;C4);C4))-MAX($A$10;))+MIN($B$10;MIN((B4&gt;B3);C4))*($A$10&gt;$B$10)
F12 : =WENN(E12&gt;0;SVERWEIS(D12;$A$2:$D$6;4;FALSCH)*E12;0)
E13 : =MAX(;MIN($B$10+($A$10&gt;$B$10);MAX((B5&gt;C5);C5))-MAX(A13;B5))+MAX(;MIN(B13;MAX((B5&gt;C5);C5))-MAX(;B5))*($A$10&gt;$B$10)+MAX(;MIN($B$10+($A$10&gt;$B$10);MIN((B5&gt;C5);C5))-MAX($A$10;))+MIN($B$10;MIN((B5&gt;B4);C5))*($A$10&gt;$B$10)
F13 : =WENN(E13&gt;0;SVERWEIS(D13;$A$2:$D$6;4;FALSCH)*E13;0)
E14 : =C12-SUMME(E10:E13)
F14 : =WENN(E14&gt;0;SVERWEIS(D14;$A$2:$D$6;4;FALSCH)*E14;0)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
28. Aug 2004, 13:44
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo zusammen,

dank des tests von fridgenep habe ich festgestellt das läuft noch nicht sauber ---

hatte ich befürchtet.

hier seine Testdaten

Zitat:
MA= Mietanfang; ME= Mietende

Bsp:

MA: 05.04.2005
ME: 04.05.2005
Ergebnis: 17 Tage im Zeitraum 2
23 Tage im Zeitraum 3

Erstens dürfte nicht ein Tag in einen der genannten Zeiträume liegen und zweitens sind es vom MA bis ME nur 30 Tage und nicht 40.


vielleicht hat ja jmd ne idee ???
Ein Hinweis noch zu meinem Lösungsansatz - ich habe für die berechnung der Zeiträume versucht die Formel von Peter Dorigo zur Ermittlung der Nachtschicht umzubauen.

http://excelformeln.de/formeln.html?welcher=9

Müsste ja vom Prinzip her machbar sein - Peter sucht nach Uhrzeiten in nem Zeitraum ich eben nach datumswerten.

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
fl618
Gibt sich Mühe


Verfasst am:
28. Aug 2004, 17:56
Rufname:
Wohnort: Wallbach, CH

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Hallo Andreas

Sorry, habe Dein Mail erst jetzt erhalten.
Ich glaube, dass Deine Formel recht komplex geworden ist. Würde die folgende, schlichtere Formel nicht schon genügen?

****editiert von ae *****

 
 ABCDEF
1 MietbeginnMietende   
2 05.04.200504.05.2005   
3      
4ZeitraumvonbisPreis Tage Preis
5124.06.200431.08.200467       -            -  
6217.12.200403.01.200567       -            -  
7311.03.200503.04.200551       -            -  
8405.05.200529.05.200551       -            -  
95sonstige 41     30     1.230  
10      
11   Total     30     1.230  
Formeln der Tabelle
E5 : =MAX(MIN(C5;$C$2)-MAX(B5;$B$2)+1;0)
F5 : =E5*D5
E6 : =MAX(MIN(C6;$C$2)-MAX(B6;$B$2)+1;0)
F6 : =E6*D6
E7 : =MAX(MIN(C7;$C$2)-MAX(B7;$B$2)+1;0)
F7 : =E7*D7
E8 : =MAX(MIN(C8;$C$2)-MAX(B8;$B$2)+1;0)
F8 : =E8*D8
E9 : =C2-B2+1-SUMME(E5:E8)
F9 : =E9*D9
E11 : =SUMME(E5:E10)
F11 : =SUMME(F5:F10)
 

_________________
Ciao
Franz

--------------------------------------------
(da ich eine engl. Excel Version verwende, kann es vorkommen, dass ich leider nicht immer die richtige deutsche Übersetzung erwische ...)
fl618
Gibt sich Mühe


Verfasst am:
28. Aug 2004, 17:58
Rufname:
Wohnort: Wallbach, CH

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

ooops

da scheint was nicht zu funktionieren.
ich schicke Dir das file per e-mail.

_________________
Ciao
Franz

--------------------------------------------
(da ich eine engl. Excel Version verwende, kann es vorkommen, dass ich leider nicht immer die richtige deutsche Übersetzung erwische ...)
ae
Mein Name ist Ente


Verfasst am:
28. Aug 2004, 18:07
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

super franz,

hab mich da irgendwie festgerannt !

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
28. Aug 2004, 18:15
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Formel für Rechnung - AW: Formel für Rechnung

Nach oben
       

Gratuliere Franz !!!

Für meinen Geschmack vom allerfeinsten !!!

Habe das File mal für die Allgemeinheit hochgeladen -

http://skripteundaufgaben.de/saison1.xls

Wer weiss, wenn unser Frager schon so nen aussagefähigen Nick hat ---- vielleicht schickt er dir ja nen 6Pack !

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Für EXCEL-PROFIS: Formel für Zahlentreffer 1 onkelbobby 2722 20. Apr 2004, 12:21
Gast Für EXCEL-PROFIS: Formel für Zahlentreffer
Keine neuen Beiträge Excel Formeln: MsgBox in Excel Formel 3 Brandlife 2885 19. Apr 2004, 18:49
Brandlife MsgBox in Excel Formel
Keine neuen Beiträge Excel Formeln: Problem mit WENN Formel 1 Hubert 2799 17. Apr 2004, 23:00
Robsl Problem mit WENN Formel
Keine neuen Beiträge Excel Formeln: Suche Formel für meinen Urlaubsplaner 1 carlos 2875 11. Apr 2004, 22:23
Klaus-Dieter Suche Formel für meinen Urlaubsplaner
Keine neuen Beiträge Excel Formeln: Formel 1 posti 636 20. März 2004, 15:51
Dick Formel
Keine neuen Beiträge Excel Formeln: Formel? 8 MantaC24NE 1355 17. März 2004, 14:40
Sebastian Formel?
Keine neuen Beiträge Excel Formeln: Formel kopieren 1 gast 1377 10. März 2004, 11:14
fridgenep Formel kopieren
Keine neuen Beiträge Excel Formeln: Mathematische Formel gesucht! 2 Gast 1367 05. März 2004, 01:18
lala Mathematische Formel gesucht!
Keine neuen Beiträge Excel Formeln: Name + Vorname als Name, Vorname = Formel??? 3 Gast 2396 02. März 2004, 18:47
Klaus-Dieter Name + Vorname als Name, Vorname = Formel???
Keine neuen Beiträge Excel Formeln: Das Problem mit der Wenn Formel ist geloest, funzt jetzt ! 5 Virtous 2285 23. Feb 2004, 15:57
xpecidy Das Problem mit der Wenn Formel ist geloest, funzt jetzt !
Keine neuen Beiträge Excel Formeln: Suche eine Formel für die Nachtschicht-Arbeitszeit 2 charlie77 4981 13. Feb 2004, 00:01
charlie77 Suche eine Formel für die Nachtschicht-Arbeitszeit
Keine neuen Beiträge Excel Formeln: Formel für Excel 1 stella 1164 14. Jan 2004, 18:58
gast Formel für Excel
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Frontpage Forum