Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Suchformular funktioniert nicht
zurück: Endlosformular Tabulatorreihenfolge von oben nach unten weiter: provision abziehen und in andere Tabelle Speichern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Ripperz
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 11:52
Rufname:

Suchformular funktioniert nicht - Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hallo,
bin neu hier und habe auch recht wenig Erfahrung mit Access. Jedoch habe ich mit viel arbeit eine kleine Datenbank geschaffen. Nun bin ich dabei ein Suchformular zu basteln. Bz. ich hab mir eins gedownloadet und versucht es bei mir anzupassen. Jetzt bekomme ich immer eine Fehlermeldung wenn ich einen Filter setzen möchte. Ich habe es hier runtergeladen: AccSampleSearchPopUp.zip

Im Orginal funktioniert das Script, nur nicht da wo ich es eingebaut habe.
Code:
Private Sub Filtern(Optional SearchFields As String = "", _
                    Optional Caption As String = "")
'Hilfsprozedur zum Filtern
On Error GoTo Err
    Dim MyFilter As String
    Dim MyOrderBy As String
    Dim MyFilterWithOrderBy As String

    With New clsSearchPopup
        .SearchFields = SearchFields
        .TableOrQuery = "Kundentabelle"
Und diese Meldung kommt auch:
Code:
Option Compare Database
Option Explicit
'Formular
Private WithEvents Form As Access.Form
'Controls
Private WithEvents cmdOK  As Access.CommandButton
Private WithEvents cmdHelp  As Access.CommandButton
rita2008
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 12:15
Rufname:
Wohnort: Berlin


AW: Suchformular funktioniert nicht - AW: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hallo,

Deine Codeausschnitte sagen leider nicht viel. Wichtiger ist, welche Fehlermeldung kommt un bei welchem Befehl der Code stehenbleibt.

_________________
mfg Rita

Antworten bitte hier im Forum, nicht als private Nachricht. Danke
Ripperz
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 12:23
Rufname:

AW: Suchformular funktioniert nicht - AW: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hallo,
also wenn ich auf das Symbol Filter klicke öffent er automatisch Visual Basic und dort steht:
Zitat:
Fehler beim Kompilieren Benutzerdefenierter Typ nicht definiert.
Was braucht Ihr denn um den Fehler zu ermitteln?
rita2008
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 12:39
Rufname:
Wohnort: Berlin

AW: Suchformular funktioniert nicht - AW: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Weche Codezeile ist dabei markiert? Und möglichst dazu, wie die entsprechende Variable definiert ist.
_________________
mfg Rita

Antworten bitte hier im Forum, nicht als private Nachricht. Danke
Ripperz
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 13:11
Rufname:

AW: Suchformular funktioniert nicht - AW: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hallo Gelb markiert ist:
Code:
Private Sub Filtern(Optional SearchFields As String = "", _
                    Optional Caption As String = "")
und das ist Rot markiert:
Code:
Option Compare Database
Option Explicit
'Formular
Private WithEvents Form As Access.Form '<== HIER ###
'Controls
Private WithEvents cmdOK  As Access.CommandButton '<== HIER ###
Private WithEvents cmdHelp  As Access.CommandButton '<== HIER ###
PS Rita: Hab dir eine PN geschickt.
rita2008
Im Profil kannst Du frei den Rang ändern


Verfasst am:
24. Jun 2007, 14:47
Rufname:
Wohnort: Berlin

AW: Suchformular funktioniert nicht - AW: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hallo Ripperz,

warum gibst Du den Link zu Deiner DB nicht hier an? Dann können auch andere die Lösung verfolgen.

1. solltest Du im VBA-Editor unter Extras/Optionen/Editor die Option "Variablendeklaration erforderlich" aktivieren. Sie bewirkt, dass im Kopf jedes Moduls der Befehl
Code:
Option Explicit
erscheint. Damit wird sofort ein Fehler ausgegeben, wenn Du eine nicht deklarierte Variable benutzt und Du bemerkst sowas nicht erst am Schluss. In bereits bestehende Moduln musst Du diese Zeile aber manuell setzen.

2. solltest Du aus der Beispieldatenbank alle Module kopieren, sonst kann es ja nicht funktionieren.

3. musst Du im VBA-Editor unter Extras/Verweise die Microsoft DAO 3.6 Object Library einbinden.

Wenn Du danach noch Probleme hast, melde Dich nochmal.

PS: Wenn Du das nächste Mal eine Beispiel-DB hochlädst ist es sinnvoll, vorher Extras/Datenbank-Dienstprogramme/Datenbank komprimieren aufzurufen. Dann geht das runterladen schneller.

_________________
mfg Rita

Antworten bitte hier im Forum, nicht als private Nachricht. Danke
Willi Wipp
Moderator


Verfasst am:
25. Jun 2007, 00:27
Rufname:
Wohnort: Raum Wiesbaden


Re: Suchformular funktioniert nicht - Re: Suchformular funktioniert nicht

Nach oben
       Version: Office XP (2002)

Hi Ripperz,

die Fehlermeldungen bei Private WithEvents ... weisen darauf hin das Du sie nicht in einem Klassenmodul abgelegt hast.

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage soll Werte ausgeben, Nz funktioniert aber nicht... 6 Butterblume 408 31. Jul 2008, 11:18
Willi Wipp Abfrage soll Werte ausgeben, Nz funktioniert aber nicht...
Keine neuen Beiträge Access Tabellen & Abfragen: Umst. Access DBs auf SQL- Paramterabfrage funktioniert nicht 0 Gast 515 06. Jun 2008, 09:09
Gast Umst. Access DBs auf SQL- Paramterabfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Warum funktioniert dieser Left Join nicht unter Access? 3 peterfarge 1443 28. Apr 2008, 17:45
peterfarge Warum funktioniert dieser Left Join nicht unter Access?
Keine neuen Beiträge Access Tabellen & Abfragen: Löschabfrage funktioniert nicht 3 Bernett22 406 08. Apr 2008, 11:40
MAPWARE Löschabfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: MDE: Abfrage funktioniert nicht mehr 0 Gast 418 23. Nov 2007, 15:14
apohl MDE: Abfrage funktioniert nicht mehr
Keine neuen Beiträge Access Tabellen & Abfragen: Update-Abfrage funktioniert nicht richtig 2 Kelley1995 508 05. Jul 2007, 16:00
Kelley1995 Update-Abfrage funktioniert nicht richtig
Keine neuen Beiträge Access Tabellen & Abfragen: Warum funktioniert diese Abfrage nicht ? 6 Mirage 804 05. Jun 2007, 12:14
Mirage Warum funktioniert diese Abfrage nicht ?
Keine neuen Beiträge Access Tabellen & Abfragen: Aktualisierungsabfrage funktioniert nicht 7 BAD TOUCH 3023 30. Mai 2007, 13:13
Gast Aktualisierungsabfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Toolbox bei Access 2000 funktioniert nicht 6 Hassos Frauchen 1634 25. Mai 2007, 13:24
KlausMz Toolbox bei Access 2000 funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Formularbasierte Abfrage funktioniert nicht 1 Rob-Bln 610 11. Mai 2007, 15:51
JörgG Formularbasierte Abfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage funktioniert nicht...hilfe!!!!! 2 bennie103 603 22. März 2007, 21:14
Gast Abfrage funktioniert nicht...hilfe!!!!!
Keine neuen Beiträge Access Tabellen & Abfragen: nz funktion funktioniert nicht 7 Sankt 4812 20. Feb 2007, 11:50
Gast nz funktion funktioniert nicht
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: JavaScript