Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
4.1 Fehlende Werte im Datenbereich: Einfluss von leeren Zell
zurück: 2.3 Spezialfälle der linearen Einfachregression weiter: 2.4 Mehrere Regressionsgeraden in einem Punkt(XY)-Diagramm Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
RajHid
VBA Gebeutelter


Verfasst am:
14. Mai 2007, 17:02
Rufname:

4.1 Fehlende Werte im Datenbereich: Einfluss von leeren Zell - 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren Zell

Nach oben
       

Hallo

ich habe auch schon mit der Regression zu tun gehabt und diverse probleme bekommen wenn ich dynamisch werte zur Regressionsanalyse hinzufügen und ausschleißen will

kann man da mit eurem code was machen ???
bin mit vba erst am anfangmeiner kariere

was ich damals versucht habe, war eine Gohst tabelle in die ich per wenn-Funktion die gewünscheten werte aus der primär-tabelle übernommen habe (Wenn(A1=1;...;...))
Problem war das für die Regressionsfunktion die werte in einer matrix stehen müssen und diese darf keine fehlerwerte enthalten da sonst #NV ausgegeben wird

was mich jedoch am meisten geärgert hat war das excel die Regression wie ich sie mir gewünscht habe richtig ausführt wenn ich die werte der Regression (R², y=f(x)) im diagramm darstellen lasse (mit einer 2. Gohsttabelle Mit Wenn dann ()NV )
auf der grafik habe ich aber leider keinen zugang zu den Daten

hoffe ihr versteht was ich will

{edit AndyRhandy: Link zum Code eingefügt}
E4M
Excel-Moderator


Verfasst am:
15. Mai 2007, 15:58
Rufname:


AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo RajHid,

Zitat:
..wenn ich dynamisch werte zur Regressionsanalyse hinzufügen und ausschleißen will

Werte dynamisch ausschließen kannst Du bspw. so:
ABC
2xyy*
3115#NV
423232
5331#NV
643030
7560#NV
864646
9717#NV
1087474
11946#NV
12104040
131187#NV
14122222
1513114#NV
16142424
171555#NV
1816120120
Formeln der Tabelle
C3 : =WENN(ISTGERADE(ZEILE(A3));B3;#NV)
C4 : =WENN(ISTGERADE(ZEILE(A4));B4;#NV)
C5 : =WENN(ISTGERADE(ZEILE(A5));B5;#NV)
C6 : =WENN(ISTGERADE(ZEILE(A6));B6;#NV)
C7 : =WENN(ISTGERADE(ZEILE(A7));B7;#NV)
C8 : =WENN(ISTGERADE(ZEILE(A8));B8;#NV)
C9 : =WENN(ISTGERADE(ZEILE(A9));B9;#NV)
C10 : =WENN(ISTGERADE(ZEILE(A10));B10;#NV)
C11 : =WENN(ISTGERADE(ZEILE(A11));B11;#NV)
C12 : =WENN(ISTGERADE(ZEILE(A12));B12;#NV)
C13 : =WENN(ISTGERADE(ZEILE(A13));B13;#NV)
C14 : =WENN(ISTGERADE(ZEILE(A14));B14;#NV)
C15 : =WENN(ISTGERADE(ZEILE(A15));B15;#NV)
C16 : =WENN(ISTGERADE(ZEILE(A16));B16;#NV)
C17 : =WENN(ISTGERADE(ZEILE(A17));B17;#NV)
C18 : =WENN(ISTGERADE(ZEILE(A18));B18;#NV)
Excel Jeanie Html
Die Zellen in Spalte A sind die x-Werte, die in Spalte C die gewünchten y-Werte.
Die Regressionsgerade wird im Punkt(XY)-Diagramm genauso richtig eingezeichnet
wie die Regressionsgleichung und das Bestimmtheitsmaß. Im Diagramm hat der
Fehlerwert #NV keinen Einfluss auf die Berechnung und Darstellung.

Um neue Werte (Datensätze) aufzunehmen, muss lediglich der Datenbereich der
Datenquelle erweitert werden. Leere Zellen haben (i.d.R.) keinen Einfluss auf die
Berechnung und Darstellung sowohl im Diagramm wie auch im Arbeitsblatt selbst.

Passt das?

Grüße

Andy
Gast



Verfasst am:
21. Mai 2007, 03:42
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

das das diagramm die daten ohne probleme schluckt weiss ich

worum es mir geht ist das die formeln in excel die daten schluken sollen auch wenn die spalten oder zeilen / matritzen fehler-werte enthalten (zb #NV)

ich habe bis jetzt noch keine möglichkeit gefunen excel mit einem bestimmten wert zu sagen diesen daten satz ignorieren und weiter machen

zb. Aufsummieren

A
1
3
4
3
#NV
7
3
1

wenn ich diese werte summiere gibt excel einen fehler aus --> #NV
ich will exel aber sagen können: wenn wert = #NV dann weiter mit nächsem wert

in jeder anderen programiersprache ist sowas möglich

als weitere schwirigkeit kommt bei der Regressionsanalyse hinzu das sich der wertebereich ständig vergrößert und das array angepasst werden muss

Excel ist bei höheren problemen einfach zu unhandlich!!!
E4M
Excel-Moderator


Verfasst am:
21. Mai 2007, 23:28
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo RajHid(?),

Zitat:
worum es mir geht ist das die formeln in excel die daten schluken sollen auch wenn die spalten oder zeilen / matritzen fehler-werte enthalten (zb #NV)

Eine Möglichkeit ist folgende Matrixformel:
AB
117
2322
343,14285714
433,55102041
5#NV2,03540098
67
73
81
Formeln der Tabelle
B1 : {=ANZAHL(WENN(ISTZAHL($A$1:$A$1000);$A$1:$A$1000))}
B2 : {=SUMME(WENN(ISTZAHL($A$1:$A$1000);$A$1:$A$1000))}
B3 : {=MITTELWERT(WENN(ISTZAHL($A$1:$A$1000);$A$1:$A$1000))}
B4 : {=VARIANZEN(WENN(ISTZAHL($A$1:$A$1000);$A$1:$A$1000))}
B5 : {=STABW(WENN(ISTZAHL($A$1:$A$1000);$A$1:$A$1000))}
Excel Jeanie Html

Zitat:
als weitere schwirigkeit kommt bei der Regressionsanalyse hinzu das sich der wertebereich ständig vergrößert und das array angepasst werden muss

Eine Möglichkeit ist, dass Du wie im obigen Beispiel bereits einen großen
Datenbereich in den Formeln berücksichtigst, wobei leere Zellen auf die
Berechnung von Formeln i.d.R. keinen Einfluss haben.
Eine weitere Möglichkeit ist den Datenbereich dynamisch über einen Namen zu
definieren, ähnlich wie in einem dynamischen Diagramm.

Grüße

Andy
Peterchen0815
Neuling


Verfasst am:
04. Jul 2007, 16:17
Rufname:


AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Tach zusammen!

Es scheint wohl doch so zu sein dass 0-Werte in den Zellen das Ergebnis der Regression beeinflussen. Sonst hätte ich in der Abfrage einfach das C152 durch C1000 ersetzt - leider ändert sich das Ergebnis.

Wie kann ich in der Formel einen dynamischen Wert verwenden? Soll heissen, wie kann ich das "C152" in folgender Formel: =RGP(C2:C152;A2:B152;WAHR;WAHR) durch eine Variable ersetzen?

Vielleicht weiß jemand auch wie ich die Anzahl aller Zeilen in einer Tabelle feststellen und in eine Variable schreiben kann?

Viele Grüße & Danke schonmal!
E4M
Excel-Moderator


Verfasst am:
05. Jul 2007, 14:43
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo Peterchen,

Zitat:
Es scheint wohl doch so zu sein dass 0-Werte in den Zellen das Ergebnis der Regression beeinflussen.
Ja, natürlich, denn null ist auch nur eine Zahl. Im obigen Beiträgen ging es (überwiegend) um Fehlerwerte.

Zitat:
Sonst hätte ich in der Abfrage einfach das C152 durch C1000 ersetzt - leider ändert sich das Ergebnis.
Leere Zellen (<>Zellen mit dem Wert null) beeinflussen manche Formeln.

Zitat:
Wie kann ich in der Formel einen dynamischen Wert verwenden?
Für die Bereiche Deiner Daten definierst Du am besten Namen:
Variable: Anzahl der Datensätze Name: n Formel: =ANZAHL($A:$A)
Variable: Bereich y-Werte Name: y Formel: =BEREICH.VERSCHIEBEN($C$2;0;0;n)
Variable: Bereich x-Werte Name: x Formel: =BEREICH.VERSCHIEBEN($A$2;0;0;n;2)

Die dynamische RGP-Formel lautet somit:
=RGP(y;x;WAHR;WAHR)

Passt das?

Grüße

Andy
Gast



Verfasst am:
06. Jul 2007, 12:02
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hi Andy!

Danke für deine schnelle Antwort!

Den ersten Teil deiner Antwort habe ich teilweise verstanden und verwenden können. Den zweiten Teil habe ich noch nicht geschafft Smile

Die Anzahl Abfrage habe ich nun, da ich die Originaldaten auch einem anderen Arbeitsblatt habe mit: =ANZAHL(Eingangsdaten!A2:Eingangsdaten!A1000) hinbekommen. Das gibt mir die Anzahl der ausgefüllten Zellen zurück. Das klappt schonmal!

Mit dem zweiten Teil habe ich noch ein Problem

=RGP(C2:C152;A2:B152;WAHR;WAHR) .. kann ich da nicht einfach das "152" durch "n" ausgelesenen Zellenwert ersetzen?

Ich könnte dir die Tabelle auch mal schicken, will sie halt nur nicht öffentlich stellen. Ist bestimmt nur ein kleines Problem, bin bloß Neuling bei Excel Sad

Grüße!
E4M
Excel-Moderator


Verfasst am:
06. Jul 2007, 12:42
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo Peterchen,
Zitat:
=RGP(C2:C152;A2:B152;WAHR;WAHR) .. kann ich da nicht einfach das "152" durch "n" ausgelesenen Zellenwert ersetzen?
Es ist möglich die Formel so anzupassen, dass das n mit aufgenommen werden kann.
Eine mögliche Lösung lautet:
Code:
{=RGP(INDIREKT("C2:C"&n+1);INDIREKT("A2:B"&n+1);WAHR;WAHR)}
n+1, da Daten beginnen ab Zeile A2

Im Anhang findest Du auch die andere Möglichkeit.

Passt das?

Grüße

Andy



peterchen.xls
 Beschreibung:

Download
 Dateiname:  peterchen.xls
 Dateigröße:  16.5 KB
 Heruntergeladen:  311 mal

Gast



Verfasst am:
06. Jul 2007, 14:05
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Sensationel!!!

Die angehängte Datei von dir funktioniert perfekt! allerdings weiß ich nicht wieso Smile

Wenn ich die Formel in meine Tabelle kopiere (und mit Umsch. Strg und Enter abschliesse) funktioniert sie nicht .. wo definierst du x,y und n?

Vielen Dank dass du dir so viel Mühe machst & Grüße!
E4M
Excel-Moderator


Verfasst am:
06. Jul 2007, 15:03
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo Peterchen,

die Variablen sind als Namen definiert. Die Namen findest Du in der Menüleiste
unter Einfügen / Namen / Definieren (bis Excel 2003)
bzw.
unter Formeln / Namen definieren (Excel 2007)

Grüße

Andy
Gast



Verfasst am:
07. Jul 2007, 00:07
Rufname:

AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

You made my day!

Vielen herzlichen Dank!

Jetzt gehts!!!
E4M
Excel-Moderator


Verfasst am:
28. Okt 2007, 11:43
Rufname:


AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren - AW: 4.1 Fehlende Werte im Datenbereich: Einfluss von leeren

Nach oben
       

Hallo zusammen,

weitere Vorgehensweisen zur Erstellung eines Diagramms bei "Fehlenden Werten im
Datenbereich" wird hier diskutiert:
XY-Diagramm von Datenbereich mit einzelnen Leerzellen

Zur Berechnung der wichtigsten Maße bei "Fehlenden Werten im Datenbereich" wird hier betrachtet:
RGP von Zellenbereich der einzelne leere Zellen enthält?

Grüße

Andy
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Workshop: Regressionsanalyse: 4.2 Dynamischer Datenbereich: dynamisches Diagramm, dynamis 28 Bamberg 16288 17. Jun 2007, 20:21
Bamberg 4.2 Dynamischer Datenbereich: dynamisches Diagramm, dynamis
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web Forum