Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
aufrunden und abrunden nach dem komma!
zurück: LinkedCell Bereich automatisch ändern weiter: Von anderem Programm Bild in Excel Einfügen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
nyra23
Im Profil kannst Du frei den Rang ändern


Verfasst am:
03. Mai 2007, 14:12
Rufname:

aufrunden und abrunden nach dem komma! - aufrunden und abrunden nach dem komma!

Nach oben
       Version: Office 2003

Hallo,

ich hab da ein kleines Rundungsproblem.

In meinem Formular soll der Mietpreis für die Produkte ausgerechnet werden. Dieser berechnet sich über den Lizenzpreis * 3,2% + Softwarepflege.
Der Lizenzpreis steht in einem Textfeld namens txtEP1. z.B. 7900,00 €
Die Softwarpflege wird in einem Textfeld namens txtSP1 ausgegeben. Die Berechnung dürfte dabei ja keine Rolle spielen.

Das mit der Berechnung funktioniert ja, aber es muss gerundet werden.

,01 bis ,20 = abrunden auf ,00
,21 bis ,69 = runden auf ,50
,70 bis ,99 = aufrunden auf ,00

kann mir da jemand den Code sagen? Wie geht das?

Danke schon mal!
Duke79
Im Profil kannst Du frei den Rang ändern


Verfasst am:
03. Mai 2007, 14:26
Rufname:


AW: aufrunden und abrunden nach dem komma! - AW: aufrunden und abrunden nach dem komma!

Nach oben
       Version: Office 2003

Hallo nyra23,

vielleicht hilft dir der link
http://www.office-loesung.de/ftopic61206_0_0_asc.php
weiter. Beim Abrunden musst du natürlich ein Minuszeichen statt dem Pluszeichen verwenden.

Duke79
ae
Mein Name ist Ente


Verfasst am:
03. Mai 2007, 14:29
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: aufrunden und abrunden nach dem komma! - AW: aufrunden und abrunden nach dem komma!

Nach oben
       Version: Office 2003

Hallo,
oder wie wäre es so:

Tabelle1

 DEF
11,19 1
21,21 1,5
31,54 1,5
41,99 2
51,67 1,5

Formeln der Tabelle
ZelleFormel
F1=WENN(REST(D1;1)<=0,2;ABRUNDEN(D1;0);WENN(REST(D1;1)<0,5;AUFRUNDEN(D1/5;1)*5;WENN(REST(D1;1)<=0,69;ABRUNDEN(D1/5;1)*5;AUFRUNDEN(D1;0))))
F2=WENN(REST(D2;1)<=0,2;ABRUNDEN(D2;0);WENN(REST(D2;1)<0,5;AUFRUNDEN(D2/5;1)*5;WENN(REST(D2;1)<=0,69;ABRUNDEN(D2/5;1)*5;AUFRUNDEN(D2;0))))
F3=WENN(REST(D3;1)<=0,2;ABRUNDEN(D3;0);WENN(REST(D3;1)<0,5;AUFRUNDEN(D3/5;1)*5;WENN(REST(D3;1)<=0,69;ABRUNDEN(D3/5;1)*5;AUFRUNDEN(D3;0))))
F4=WENN(REST(D4;1)<=0,2;ABRUNDEN(D4;0);WENN(REST(D4;1)<0,5;AUFRUNDEN(D4/5;1)*5;WENN(REST(D4;1)<=0,69;ABRUNDEN(D4/5;1)*5;AUFRUNDEN(D4;0))))
F5=WENN(REST(D5;1)<=0,2;ABRUNDEN(D5;0);WENN(REST(D5;1)<0,5;AUFRUNDEN(D5/5;1)*5;WENN(REST(D5;1)<=0,69;ABRUNDEN(D5/5;1)*5;AUFRUNDEN(D5;0))))

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
bst
Programmierer


Verfasst am:
03. Mai 2007, 14:39
Rufname: Bernd
Wohnort: Ilsfeld

AW: aufrunden und abrunden nach dem komma! - AW: aufrunden und abrunden nach dem komma!

Nach oben
       Version: Office 2003

Auch Hallo,

=RUNDEN(2*A1;0)/2

wäre hier M.E. die übliche Variante zu runden.

,24 wird hier aber noch abgerundet und erst ab ,75 aufgerundet.

cu, Bernd
ae
Mein Name ist Ente


Verfasst am:
03. Mai 2007, 14:43
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: aufrunden und abrunden nach dem komma! - AW: aufrunden und abrunden nach dem komma!

Nach oben
       Version: Office 2003

lach,

hallo Bernd,

lass es nicht Deine Lösung sein - dann beiss ich mich in den Hintern - das war mein erster Gedanke daß man so ja in der Regel nicht rundet -

Manchmal wäre es einfacher nachzufragen Laughing

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: bei Datumseingabe Punkt in Komma foramtieren 2 fried11 507 22. Sep 2008, 16:31
fried11 bei Datumseingabe Punkt in Komma foramtieren
Keine neuen Beiträge Excel Formeln: Aufrunden von Zahlen 22 Sabrina123 7589 11. Sep 2008, 08:19
Sabrina123 Aufrunden von Zahlen
Keine neuen Beiträge Excel Formeln: Komma innerhalb einer Formel einfügen 8 sandsonne 798 19. Aug 2008, 12:31
sandsonne Komma innerhalb einer Formel einfügen
Keine neuen Beiträge Excel Formeln: Auf - Abrunden 20 rolixc 2132 24. Jun 2008, 07:21
rolixc Auf - Abrunden
Keine neuen Beiträge Excel Formeln: Adresse, Komma getrennt in 3 zellen vereinzeln. 3 molot 1297 17. Jun 2008, 10:38
molot Adresse, Komma getrennt in 3 zellen vereinzeln.
Keine neuen Beiträge Excel Formeln: abrunden, aber automatisch berechnen und abziehen 15 Promaetheus 2917 26. Okt 2007, 10:42
Promaetheus abrunden, aber automatisch berechnen und abziehen
Keine neuen Beiträge Excel Formeln: ABRUNDEN/ KLEINER ALS?? 5 Nexi 502 31. Jul 2007, 11:09
Gast ABRUNDEN/ KLEINER ALS??
Keine neuen Beiträge Excel Formeln: Komma gegen Punkt + vice versa- PROBLEM Tabelle verknüpft 7 Tobi123 898 13. Jul 2007, 14:23
urs Komma gegen Punkt + vice versa- PROBLEM Tabelle verknüpft
Keine neuen Beiträge Excel Formeln: Name, Vorname, aus zwei Zellen verbinden mit Komma trennen 7 financialmaf 22271 28. Jun 2007, 11:56
Mario79 Name, Vorname, aus zwei Zellen verbinden mit Komma trennen
Keine neuen Beiträge Excel Formeln: Unterschiedl. Beträge in Zelle auf bestimmten Wert aufrunden 2 Cyberpirats 700 09. Jun 2007, 14:42
Cyberpirats Unterschiedl. Beträge in Zelle auf bestimmten Wert aufrunden
Keine neuen Beiträge Excel Formeln: Abrunden von Zeiten 2 Strahlemann 397 03. März 2007, 16:26
Strahlemann Abrunden von Zeiten
Keine neuen Beiträge Excel Formeln: Mit "AUFRUNDEN" nur ungerade Beträge aufrunden 11 flyingbob 1200 20. Jan 2007, 13:00
flyingbob Mit "AUFRUNDEN" nur ungerade Beträge aufrunden
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: CSS Forum