Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Mittelwert ohne doppelte und nur wenn Bedingung erfüllt
zurück: Vergleich Hilfe weiter: Formel nach unten ziehen, nur die "1" soll größer Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
HolgerH
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2007, 11:59
Rufname:

Mittelwert ohne doppelte und nur wenn Bedingung erfüllt - Mittelwert ohne doppelte und nur wenn Bedingung erfüllt

Nach oben
       Version: Office 2003

Hallo Zusamen,

ich habe wieder mal ein Problem bei dem ich Eure Hilfe benötige. In der Spalte A habe ich Namen von Personen, in B steht deren Geburtsdatum, in C wird das Alter über DATEDIF berechnet und in D steht deren Geschlecht.

Ich möchte nun den Mittelwert des Alters berechnen und zwar:

1. Von allen gemeinsam, wobei mehrfach vorkommende Namen nur einmal berücksichtigt werden sollen
2. Vann allen weiblichen Personen (doppelte nur einmal)
3. Von allen männlichen Peersonen (doppelte natürlich nur einmal)

Folgerne Formeln von Euch haben mir sehr geholfen:

Um zu zählen wieviele Personen anwesend waren ohne die Doppelten zu berücksichtigen:
{=SUMME(WENN('2003'!A3:A200<>"";1/ZÄHLENWENN('2003'!A3:A200;'2003'!A3:A200)))}
Um nur die männlichen oder weiblichen Personen zu zählen:
{=SUMME(WENN(D5:E500="m";WENN(ZÄHLENWENN(A5:A500;A5:A500)="1";1/ZÄHLENWENN(A5:A500;A5:A500))))}

Aber ich bekomme es nicht hin, dass das mittlere Alter aller Personen, nur der weiblichen und nur der männlichen berechnet wird.

Bitte Hilfe.... Smile

Tabelle1

 ABCD
1NameGeburtstagAlterGeschlecht
2Name 107.01.196740m
3Name 224.09.193868w
4Name 107.01.196740m
5Name 325.05.195353m
6Name 425.05.195353w
7Name 525.05.195353m
8Name 224.09.193868w
9Name 107.01.196740m
10Name 224.09.193868w
11Name 623.06.195551m
12Name 325.05.195353m

Formeln der Tabelle
ZelleFormel
C2=WENN(ISTLEER(A2);"";DATEDIF(B2;HEUTE();"Y"))
C3=WENN(ISTLEER(A3);"";DATEDIF(B3;HEUTE();"Y"))
C4=WENN(ISTLEER(A4);"";DATEDIF(B4;HEUTE();"Y"))
C5=WENN(ISTLEER(A5);"";DATEDIF(B5;HEUTE();"Y"))
C6=WENN(ISTLEER(A6);"";DATEDIF(B6;HEUTE();"Y"))
C7=WENN(ISTLEER(A7);"";DATEDIF(B7;HEUTE();"Y"))
C8=WENN(ISTLEER(A8);"";DATEDIF(B8;HEUTE();"Y"))
C9=WENN(ISTLEER(A9);"";DATEDIF(B9;HEUTE();"Y"))
C10=WENN(ISTLEER(A10);"";DATEDIF(B10;HEUTE();"Y"))
C11=WENN(ISTLEER(A11);"";DATEDIF(B11;HEUTE();"Y"))
C12=WENN(ISTLEER(A12);"";DATEDIF(B12;HEUTE();"Y"))


Excel Jeanie Html
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
22. Apr 2007, 14:12
Rufname:
Wohnort: Oldenburg i.O.

AW: Mittelwert ohne doppelte und nur wenn Bedingung erfüllt - AW: Mittelwert ohne doppelte und nur wenn Bedingung erfüllt

Nach oben
       Version: Office 2003

Hi,
wenn Du Dir eine Hilfsspalte (E) gönnst und dort mit
Code:
ZÄHLENWENN(A$2:A2;A2)

zählst, wie häufig die Namen vorhanden sind (Ergebnis 1 wird im Folgenden jeweils genutzt), dann kannst Du mit Zählenwenn, Summewenn, Summenprodukt arbeiten:

Anzahl aller
Code:
=ZÄHLENWENN(E:E;1)

Anzahl männlich
Code:
=SUMMENPRODUKT((E2:E12=1)*(D2:D12="m"))

mittleres Alter
Code:
=SUMMEWENN(E:E;1;C:C)/ZÄHLENWENN(E:E;1)

mittleres Alter männlich
Code:
=SUMMENPRODUKT((E2:E12=1)*(D2:D12="m")*C2:C12)/SUMMENPRODUKT((E2:E12=1)*(D2:D12="m"))

Die Mädels schaffst Du selbst.

_________________
urs grüßt
HolgerH
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2007, 15:06
Rufname:


AW: Mittelwert ohne doppelte und nur wenn Bedingung erfüllt - AW: Mittelwert ohne doppelte und nur wenn Bedingung erfüllt

Nach oben
       Version: Office 2003

Halo urs,

vielen Dank für den Tip, aber ich habe mittlerweile selbst eine Lösung gefunden ohne Hilfsspalte.

Mit dieser Formel:
SUMME(WENN(A2:A100<>"";(1/ZÄHLENWENN(A2:A100;A2:A100)*(C2:C100))))
summiere ich das Alter aller Pesonen, wobei mehrfach vorkommende Personen nur einmal berücksichtigt werden. Den ersten Teil benötige ich nur für den Fall, dass eine längere Liste berücksichtigt werden soll, die aber noch nicht vollständig ausgefült ist.
Diese Formel teile ich dann durch die Anzahl aller Personen:
SUMME(WENN(A2:A100<>"";1/ZÄHLENWENN(A2:A100;A2:A100))

Um nur die Männer zu berücksichtigen ergänze ich beide Formeln wie folgt:

Alter aller Männer:
SUMME(WENN(A2:A100<>"";(1/ZÄHLENWENN(A2:A100;A2:A100)*(C2:C100)*(D2:D100="m"))))
Geteilt durch die Anzahl aller Männer:
SUMME(WENN(A2:A100<>"";(1/ZÄHLENWENN(A2:A100;A2:A100)*(D2:D100="m"))))

Für die Frauen muß das "m" dann nur durch ein "w" ersetzt werden... Smile


Kennt jemand vielleicht eine einfachere (kürzere) Formel?

LG,

Holger
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Mittelwert bei nicht zusammenhängendem Bereich 8 tom_r 922 15. Nov 2005, 13:04
tom_r Mittelwert bei nicht zusammenhängendem Bereich
Keine neuen Beiträge Excel Formeln: Prüfung auf doppelte Einträge 1 OLLI_S 1650 31. Okt 2005, 17:50
Hübi Prüfung auf doppelte Einträge
Keine neuen Beiträge Excel Formeln: Doppelte Einträge herausfiltern 3 Jericho2000 6004 21. Okt 2005, 08:46
< Peter > Doppelte Einträge herausfiltern
Keine neuen Beiträge Excel Formeln: Mittelwert 1 dennism 613 27. Sep 2005, 13:27
fridgenep Mittelwert
Keine neuen Beiträge Excel Formeln: doppelte daten suchen 2 chrispx 1428 26. Aug 2005, 09:27
chrispx doppelte daten suchen
Keine neuen Beiträge Excel Formeln: Zufallszahl nicht doppelte werte?? 2 Knicky 1831 06. Jul 2005, 14:39
Gast Zufallszahl nicht doppelte werte??
Keine neuen Beiträge Excel Formeln: Gewichteten Mittelwert bilden - Fehler berücksichtigen 10 bavella 1121 11. Jun 2005, 17:01
bavella Gewichteten Mittelwert bilden - Fehler berücksichtigen
Keine neuen Beiträge Excel Formeln: Mittelwert aus Liste bestimmen 2 cb3000 1329 08. Jun 2005, 10:21
cb3000 Mittelwert aus Liste bestimmen
Keine neuen Beiträge Excel Formeln: Wenn Bedingung ganze Zeile in endere Arbeitsmappe kopieren 2 Unregistered7 1556 05. Mai 2005, 22:32
Gast Wenn Bedingung ganze Zeile in endere Arbeitsmappe kopieren
Keine neuen Beiträge Excel Formeln: Formel erfüllt ihren Zweck und löscht sich 16 Aleks 1320 28. März 2005, 12:53
ae Formel erfüllt ihren Zweck und löscht sich
Keine neuen Beiträge Excel Formeln: Hyperlink mit Bedingung 3 NcMandy 839 19. März 2005, 19:09
Hübi Hyperlink mit Bedingung
Keine neuen Beiträge Excel Formeln: Doppelte Daten entfernen 1 Sabine1980 2206 08. Feb 2005, 18:19
Thomas Ramel Doppelte Daten entfernen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen