Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Nur 3 relevante Stellen einer Zahl anzeigen
zurück: automatisch Text in Spalten weiter: Wochenende im Format farbig kennzeichnen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
21. Feb 2007, 16:29
Rufname:

Nur 3 relevante Stellen einer Zahl anzeigen - Nur 3 relevante Stellen einer Zahl anzeigen

Nach oben
       Version: Office XP (2002)

Hi,
eigentlich kenn ich mich mit Excel ganz gut aus, habe aber jetzt ein Prob.
Ich will ein Benutzer definiertes Format erstellen, bei dem von den Ergebnissen einer Spalte immer nur 3 relevante Stellen dargestellt werden sollen, der Rest sollen Nullen sein.
5,25 -> 5,25 €
15,25 -> 15,30 €
155,25 -> 155,00 €
1255,25 -> 1.260,00 €
1253,22 -> 1.250,00 €
12225,11 -> 12.200,00 €
12255,66 -> 13.300,00 €
Ich möchte es mit der bedingten Formatierung lösen und nicht mit Wenn(), weil ich dann -zig Formeln ändern muss.
1. geht das und
2. wie
Hab schon alles mögliche versucht, kriege das aber nicht hin, auch über die Forumssuche habe ich nichts gefunden.
Für Hilfe bedanke ich mich im Voraus.
Dieter
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
22. Feb 2007, 23:52
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Nur 3 relevante Stellen einer Zahl anzeigen - AW: Nur 3 relevante Stellen einer Zahl anzeigen

Nach oben
       Version: Office XP (2002)

Hi Dieter,

selbst auf die Gefahr, gesteinigt zu werden, dieser Vorschlag
Tabelle1

 AB
10,250,25
25,255,25
315,2515,30
4155,25155,00
51.255,251.260,00
61.253,221.250,00
712.225,1112.200,00
812.255,6612.300,00
91.234.567,221.230.000,00
1012.355.678,2512.400.000,00

Formeln der Tabelle
ZelleFormel
B1=RUNDEN(A1;6-LÄNGE(A1))
B2=RUNDEN(A2;6-LÄNGE(A2))
B3=RUNDEN(A3;6-LÄNGE(A3))
B4=RUNDEN(A4;6-LÄNGE(A4))
B5=RUNDEN(A5;6-LÄNGE(A5))
B6=RUNDEN(A6;6-LÄNGE(A6))
B7=RUNDEN(A7;6-LÄNGE(A7))
B8=RUNDEN(A8;6-LÄNGE(A8))
B9=RUNDEN(A9;6-LÄNGE(A9))
B10=RUNDEN(A10;6-LÄNGE(A10))

Excel Jeanie Html
Bedingte Formatierung scheidet schon mal prinzipiell aus und Benutzerdef. Format geht leider auch nicht.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
fridgenep
Gast


Verfasst am:
23. Feb 2007, 12:32
Rufname:

AW: Nur 3 relevante Stellen einer Zahl anzeigen - AW: Nur 3 relevante Stellen einer Zahl anzeigen

Nach oben
       Version: Office XP (2002)

Hallo Hübi,

super Lösung! Gefällt mir.
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
24. Feb 2007, 00:41
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg

AW: Nur 3 relevante Stellen einer Zahl anzeigen - AW: Nur 3 relevante Stellen einer Zahl anzeigen

Nach oben
       Version: Office XP (2002)

Hi Fridgenep,

ein blindes Excel-Huhn findet halt auch einmal ein Korn. Laughing
Schade um den sinnlos verschwendeten Rest-Gehirnschmalz.

Dieter hat es sicher eleganter gelöst und verheimlicht uns die Lösung. Sad

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Gast



Verfasst am:
24. Feb 2007, 18:43
Rufname:


AW: Nur 3 relevante Stellen einer Zahl anzeigen - AW: Nur 3 relevante Stellen einer Zahl anzeigen

Nach oben
       Version: Office XP (2002)

Nee, nix verheimlichen, ich hab nur einige Tage nicht nachgesehen, weil anfangs keine Antworten kamen.
Ich hab das so gelöst, Wert in A1:
Wenn(A1>=1000;Runden(A1/10;0)*10;Wenn(A1>=100;Runden(A1;0);Wenn(A1>=10;Runden(A1;1);Runden(A1;2))))
Mit Benutzer definiertem Format schein es leider nicht zu gehen.
Trotzdem vielen Dank für die Antworten.
Dieter
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Wert nicht als 0 anzeigen,aber trotzdem damit rechnen können 4 Bleppomueller 1319 20. Jun 2005, 14:29
Gast Wert nicht als 0 anzeigen,aber trotzdem damit rechnen können
Keine neuen Beiträge Excel Formeln: Zahl mit Zahl ersetzen und mit der Formel Multiplizieren??? 7 Iggy 912 14. Apr 2005, 21:53
ae Zahl mit Zahl ersetzen und mit der Formel Multiplizieren???
Keine neuen Beiträge Excel Formeln: Verknüpfungen mit langem Pfad, nicht anzeigen! 2 Nikos 706 29. März 2005, 13:28
Nikos Verknüpfungen mit langem Pfad, nicht anzeigen!
Keine neuen Beiträge Excel Formeln: Zahl durch Wort ersetzen. 1 Carrear 3152 23. Feb 2005, 15:46
ae Zahl durch Wort ersetzen.
Keine neuen Beiträge Excel Formeln: Datum rot anzeigen 2 Mimoss 2046 15. Feb 2005, 23:07
AnBo Datum rot anzeigen
Keine neuen Beiträge Excel Formeln: zahl unsichtbar 1 traum1954 815 09. Feb 2005, 23:39
Scelina zahl unsichtbar
Keine neuen Beiträge Excel Formeln: Wert nur einmal anzeigen 3 User001 21427 04. Feb 2005, 15:18
rainberg Wert nur einmal anzeigen
Keine neuen Beiträge Excel Formeln: zellwert 2-stellig anzeigen - eingabe + rechnen 5-stellig 5 strandexpress 1207 22. Jan 2005, 15:35
Arnim zellwert 2-stellig anzeigen - eingabe + rechnen 5-stellig
Keine neuen Beiträge Excel Formeln: Zahl um 1 erhöhen pro gedrucktes Blatt 0 redfin 496 18. Jan 2005, 10:22
redfin Zahl um 1 erhöhen pro gedrucktes Blatt
Keine neuen Beiträge Excel Formeln: fortlaufende zahl in spalte - funktion? 2 lifius 1741 10. Dez 2004, 19:45
lifius fortlaufende zahl in spalte - funktion?
Keine neuen Beiträge Excel Formeln: Druckdatum anzeigen 0 Stefan L. 1122 23. Nov 2004, 10:02
Stefan L. Druckdatum anzeigen
Keine neuen Beiträge Excel Formeln: Tendenz anzeigen 1 Coupi 3156 10. Nov 2004, 22:24
Nepumuk Tendenz anzeigen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum